none
Custom Button on Ribbon not visible in Wiki Page Ribbon.Documents.Manage RRS feed

  • Question

  • Hi I've added a button on my ribbon.

    its location is Ribbon.Documents.Manage.Controls._children

    It works as expected in all of my Document Library
    But it is now working on my Wiki Pages Library.

    <?xml version="1.0" encoding="utf-8"?>
    <Elements xmlns="http://schemas.microsoft.com/sharepoint/">
      <CustomAction
    ScriptSrc ="SiteFeedback.js"
    Location="ScriptLink">
      </CustomAction>
     <CustomAction
     Id="KM.SharePoint.Documents.Ribbon.SendFeedback"
     RegistrationType="List"
     RegistrationId="101"
     Location="CommandUI.Ribbon"
     Rights="ViewListItems">
        <CommandUIExtension>
          <CommandUIDefinitions>
            <CommandUIDefinition
               Location="Ribbon.Documents.Manage.Controls._children">
              <Button
               Id="Ribbon.Documents.Manage.Controls.SendFeedback"
               Alt="Send Feedback"
               Sequence="1"
               Image32by32="/_layouts/Feedback/images/Comment32x32.png"
               Image16by16="/_layouts/Feedback/images/Comment16x16.png"
               Command="Command.Documents.SendFeedback"
               LabelText="Send Feedback"
               TemplateAlias="o1"
               CommandType="General"/>
            </CommandUIDefinition>
          </CommandUIDefinitions>
          <CommandUIHandlers>
            <CommandUIHandler
             Command="Command.Documents.SendFeedback"
             EnabledScript="javascript:EnableSendFeedbackButton();"
             CommandAction="javascript:ribbon_openModalDialogFeedBack() ;" />
          </CommandUIHandlers>
        </CommandUIExtension>
      </CustomAction>
    </Elements>

    Please help me with this error.

    Thanks,

    check.on.it

    Thursday, April 12, 2012 6:21 AM

Answers

All replies