none
How to change already published InfoPath form as web / browser enabled web form? RRS feed

  • Question

  • I have created an Infopth 2007 form. Published in sharepoint 2007. I forgot to made it as web enabled.

    Now, i cannot reppublish the same form as it has connected with 3 workflows. Is there any property to made it as web enabled?

    I have updated as web enabled properties in form library advanced settings. It is opening when I edit / open enisting form in the browser. If I try to create new, I am not able to open in the browser.

    I have to open new form also in the browser,

     


    - GEM
    • Moved by Mike Walsh FIN Thursday, May 26, 2011 10:39 AM InfoPath q (From:SharePoint - Setup, Upgrade, Administration and Operation (pre-SharePoint 2010))
    • Edited by GEMZz Wednesday, June 1, 2011 6:35 AM
    Thursday, May 26, 2011 10:28 AM

All replies

  • You have to re-publish it to make it browser-enabled.  Why do the workflows keep you from re-publishing?  Those shouldn't get in the way.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Friday, May 27, 2011 2:19 AM
  • On the form library settings page, under Advanced Settings, you can change the default open behavior to "open in the browser".

    If you leave the default, the form will open in the InfoPath client if it sees that you have the client installed.  This setting forces it to open in the browser no matter what.


    Laura Rogers, MCSE, MCTS
    SharePoint911: SharePoint Consulting
    Blog: http://www.sharepoint911.com/blogs/laura
    Twitter: WonderLaura
    Beginning SharePoint 2010: Building Business Solutions with SharePoint
    Friday, May 27, 2011 3:46 AM
  • I thought he said he did that, but he wasn't super clear on it.  The form still needs to be browser-enabled in order to reliably open in the browser.  If that check box on the publish wizard is not checked, it will error for the user or open in the Filler.  Remember this is also 2007.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Friday, May 27, 2011 4:05 AM
  • I cannot publish the same page by doing the said modification (check box - select).

    There is no managed code.(C# code)

    Is there any other process to make it browser enabled?

    I do generally, if I change anything in the Infopath form, as it is restriced to publish -

    for any UI changes - 

    saving the form into my desktop from the site, edit, and save the modified form "Save As Source File" ..

    select Template.xml,

    changing href as server url, I can get a list of files...

    I can upload only template in the Form library settings - content typre FORM settings - List Content Type Advanced Settings: Form.

    Hence, Is there any setting to change in the Template.xml file to to fix this issue?

     

     


    - GEM
    Friday, May 27, 2011 7:49 AM
  • Wow, why do you do those steps?  YOu do not ever upload a form template unless it's admin-approved and being put in Central Admin.  YOu just re-publish the form, but first you go to File > Info > Advanced Form Options > Compatibility > Switch to Web Browser Form.  Then, go through the publishing wizard and check the box for browser-enabling on the page where you select Document Library.

    You should not be editing the manifest directly nor should you be uploading the form template.

    You don't touch Template.xml at all either.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Friday, May 27, 2011 2:09 PM
  • Thanks for your suggestion Clayton.

    But, We are using this Infopath form since 1.2 year. It has a lot of dependencies, controls and it has 3  Nintex workflows connected. If I publish it as you suggested,( it could be a new Infopath form ), will it effect workflows and other dependencies?

     

     


    - GEM
    Monday, May 30, 2011 6:09 AM