locked
Quick Launch on newly Created Web Part page in Sharepoint RRS feed

  • Question

  • Hi,

    I am new in sharepoint World so please elaborate whatever you are going to explain.

    I want to enable Quick Launch on newly Created Web Part page in Sharepoint.

    Please Tell me answer asap!!!i need It!!!

    Any help will be appreciated!

    Thanx!

    • Edited by NirajZ Wednesday, August 1, 2012 8:13 AM
    Wednesday, August 1, 2012 8:10 AM

Answers

  • Hi Niraj,

    I got a solution how to enable quick launch bar on web part pages by default.

    Refer following code.

    Paste this within the <head> tag.  This will enable jquery:

    <!– Include jquery library –>
    <script src=”http://code.jquery.com/jquery-latest.js”></script>

    Paste this within the <form> tag.  This will ensure that the left navigation is always visible:

    	<script type="text/javascript">
      
       $(document).ready(function() 
       {
         $("#s4-leftpanel").show();
         $(".s4-ca").css('margin-left', '155px');
       }
       );
    </script>

    Cheers,

    Balaji More


    • Edited by Balaji More Friday, August 3, 2012 8:50 AM
    • Marked as answer by NirajZ Tuesday, August 7, 2012 7:11 AM
    Friday, August 3, 2012 8:50 AM

All replies

  • What you want to know? How to manage quick Launch?

    v1. You can go to Site Settings, ang choose Navigation from Look and Feel Area.

    or

    v2. Open the address: <a href="http:///_layouts/quiklnch.aspx">http://<fullurl>/_layouts/quiklnch.aspx

    Hope helps.


    http://valygreavu.wordpress.com/

    Wednesday, August 1, 2012 8:17 AM
  • I know these settings, I am asking about web part page??

    i want to make that quick launch available on every web part page i want add in master page.

    Just like master page concept!!!



    • Edited by NirajZ Wednesday, August 1, 2012 9:06 AM
    Wednesday, August 1, 2012 8:50 AM
  • Hi Niraj,

    I have same problem to show quick launch on newly created web part page.

    I want to enable by default quick launch bar on web part page using master page.

    Let me know if you solve this issue.

    Thanks

    Balaji More


    • Edited by Balaji More Wednesday, August 1, 2012 11:12 AM
    Wednesday, August 1, 2012 11:11 AM
  • Hi,

    The Blank Web Part page Page Layout includes the Quick Launch by default. You could always create your own custom page layout that does not include the css used to hide the quick launch bar.


    Eric Overfield - PixelMill - blog.pixelmill.com/ericoverfield - @EricOverfield

    Wednesday, August 1, 2012 5:41 PM
  • Hi Eric,

    Thanks for your reply.

    Please explain little bit more. Now I am stuck in this problem.

    I have solve this problem in SharePoint server but i want to use in SharePoint Online.

    because we can't get access of 14 hive in SharePoint online.

    Thanks

    Balaji More

    Friday, August 3, 2012 6:17 AM
  • Hi Niraj,

    I got a solution how to enable quick launch bar on web part pages by default.

    Refer following code.

    Paste this within the <head> tag.  This will enable jquery:

    <!– Include jquery library –>
    <script src=”http://code.jquery.com/jquery-latest.js”></script>

    Paste this within the <form> tag.  This will ensure that the left navigation is always visible:

    	<script type="text/javascript">
      
       $(document).ready(function() 
       {
         $("#s4-leftpanel").show();
         $(".s4-ca").css('margin-left', '155px');
       }
       );
    </script>

    Cheers,

    Balaji More


    • Edited by Balaji More Friday, August 3, 2012 8:50 AM
    • Marked as answer by NirajZ Tuesday, August 7, 2012 7:11 AM
    Friday, August 3, 2012 8:50 AM
  • Hi,

    If you are willing to update the master page to effect all pages then I would recommend a slightly easier way that won't require the overhead of jQuery. Don't get me wrong, I think that jQuery has it's place but the following css in your master page, before the closing </body> tag, should do the trick.

    <style type="text/css">
    #s4-leftpanel {display: block !important;}
    .s4-ca {margin-left: 155px !important;}
    </script>

    I also do not like the use of the !important tag, but in this case you need to make sure that you override all previous css. I know that normally you would never place inline styles in the <body> tag, and if you do they should be near the top but the problem is that many page layouts have similar styles inline, in the middle of the page. By adding this code before the closing </body> tag you are sure that your css will in fact be used.

    The jQuery method is more elegent but again, the tradeoff is the overhead of downloading and processing all of that code.

    I hope this helps.


    Eric Overfield - PixelMill - blog.pixelmill.com/ericoverfield - @EricOverfield

    Friday, August 10, 2012 3:11 AM
  • Hi Eric,

    Thanks for your reply.

    You suggested above css i have already used in my custom master page it works fine to enable quick launch bar on every web part page,

    but when you search on site level, search result is not display in proper layout when we that css.

    Following is my another thread to layout about search result.

    http://social.msdn.microsoft.com/Forums/en/sharepoint2010general/thread/3e02b802-28f9-4bf8-a424-fdb46236b959

    Thanks

    Balaji More

    Friday, August 10, 2012 4:46 AM
  • Hi Balaji,

    The search results page uses the minimal.master Master Page which does not include the same quick launch code. You would have to add that back in. I would try copying the QL code directly from the v4.master and adding it into your own minimal.master. It may be trickly though as the search results page rendered the entire page including it's own left navigation bar so getting them to line up may require javascript.


    Eric Overfield - PixelMill - blog.pixelmill.com/ericoverfield - @EricOverfield

    Wednesday, August 15, 2012 7:50 PM
  • Hi,

    Its very simple to show back Quick launch on Web part Page which is by Default  deactivate. 

    Follow the following easy step.

    1. Site Actions -> View All Site Content
    2. Click the Create Button (upper left)
    3. Select 'Page' under the Filter By: section
    4. Click the Create Button (middle right)
    5. Select 'Header, Right Column, Body' from the Layouts list
    6. Note the Save Location, so you know where to look for it. (Shared Documents may be the default.)
    7. Open SharePoint Designer 2010, and open the site
    8. Edit the page
    9. Click on the Advanced Mode ribbon button!!! (It's on the Home tab)
    10. Scroll down to line 34 and look for the following code:
    <SharePoint:UIVersionedContent ID="WebPartPageHideQLStyles" UIVersion="4" runat="server">
    <ContentTemplate>
    <style type="text/css">
    body #s4-leftpanel {
    display:none;
    }
    .s4-ca {
    margin-
    }
    </style>
    </ContentTemplate>
    </SharePoint:UIVersionedContent>

    11. Comment it out like the following:
    <%-- 
    [Code Block] 
    --%>

    12. Scroll down to line 60 and look for the following code:
    <asp:Content ContentPlaceHolderId="PlaceHolderNavSpacer" runat="server"></asp:Content>
    <asp:Content ContentPlaceHolderId="PlaceHolderLeftNavBar" runat="server"></asp:Content>

    13. Comment it out as well.
    14. Save the Page.
    15. Test in Browse........

    And Back into Business.............

    • Proposed as answer by Ramana V Friday, February 12, 2016 8:38 PM
    Wednesday, July 17, 2013 1:37 PM
  • Hi Sameer,

    Follow the steps it shows up the left Navigation in SP Designer but when I go back out to browser it gives error "Only Content controls are allowed directly in a content page that contains Content controls. "

    Any idea?

    Friday, January 3, 2014 9:05 AM
  • I got the same error when i commented out those place holder code lines. Did anyone get to resolve this error?
    Thursday, April 10, 2014 8:09 PM
  • It sounds as though you are trying to add this code to a page layout. You can only add this to a page layout if you place the code within a  <asp:Content> block.


    Eric Overfield - PixelMill - blog.pixelmill.com/ericoverfield - @EricOverfield

    Tuesday, April 15, 2014 6:53 PM
  • Check whether you have commented out properly.

    I faced same issue as i didnt comment out properly.

    Comment it out like the following:
    <%-- 
    [Code Block] 
    --%>

    Wednesday, April 16, 2014 6:18 AM