locked
Hide All Day Event and Recurrence filed from SharePoint Calendar in SharePoint 2013 RRS feed

  • Question

  • Hi,

    I have created calendar using reservation content type in SharePoint 2013.But here i want to hide/disable the "All Day Event" and "Recurrence" field.

    I am successful to make it hidden using SharePoint designer.But what i see after hiding these,calendar does not allow me to save the event.It's throwing the following error.

    Please help me to hide/disable these fields using JavaScript or anything else.

    Waiting for your quick response

    Thank you

    

    

    Monday, May 26, 2014 6:23 AM

Answers

  • Hi Adiiti,

    The error message might occur for deleting the recurrence column. Please create a new calendar to test the issue.

    To do this, please go to list settings, and activate “Allow management of content types” in the Advanced settings. Then perform the steps I mentioned above, since by default there is only event content type in a calendar list. So in the content types section, click on event.

    In addition, please provide information about how you made the column hidden for me to reproduce the issue.

    Regards,


    Rebecca Tu
    TechNet Community Support

    • Marked as answer by star.wars Monday, June 9, 2014 1:57 AM
    Wednesday, May 28, 2014 1:48 AM

All replies

  • You can use jquery to hide columns from the list view.

    Check following post to get the details:

    http://www.the-north.com/sharepoint/post/Hide-Unwanted-Fields-On-Calendar-Form

    http://spcolumnpermission.codeplex.com/

    Monday, May 26, 2014 6:57 AM
  • Hi,

    Thanks for your quick reply.

    I tried to add j query using the above link.

    But it seems working not properly.

    By using the j query,sometime it hide the fields and sometime it does not.

    Please help

    Thank you

    Tuesday, May 27, 2014 6:54 AM
  • Hi Aditi,

    You could hide unwanted content type columns. Please follow:

    1. In the calendar list > Edit List in SharePoint Designer
    2. In the Content types section > click Reservations
    3. In the customization section > click Edit content type columns
    4. Select All Day Event > click Administration Web Page
    5. In Column Settings > Hidden(Will not appear in forms)

    Regards,


    Rebecca Tu
    TechNet Community Support


    • Edited by Rebecca Tu Tuesday, May 27, 2014 7:02 AM
    Tuesday, May 27, 2014 7:02 AM
  • Hi,

    Thanks for your reply.

    Then how to hide recurrence field.

    I follow the same way as "All Day Event".But it throwing the above error.

    waiting for your helpful response

    Thank you


    • Edited by Aditi Das Tuesday, May 27, 2014 10:26 AM
    Tuesday, May 27, 2014 8:20 AM
  • Hi Adiiti,

    The error message might occur for deleting the recurrence column. Please create a new calendar to test the issue.

    To do this, please go to list settings, and activate “Allow management of content types” in the Advanced settings. Then perform the steps I mentioned above, since by default there is only event content type in a calendar list. So in the content types section, click on event.

    In addition, please provide information about how you made the column hidden for me to reproduce the issue.

    Regards,


    Rebecca Tu
    TechNet Community Support

    • Marked as answer by star.wars Monday, June 9, 2014 1:57 AM
    Wednesday, May 28, 2014 1:48 AM
  • Thanks - Perfect just what I needed
    Tuesday, April 25, 2017 11:43 AM
  • Here is a solution with javascript
    http://jurisinnenad.blogspot.com/2015/01/hide-all-day-event-and-recurrence.html
    Friday, July 13, 2018 8:19 AM
  • I found this solution on https://sharepoint.stackexchange.com/questions/122987/how-do-you-hide-all-day-event-and-recurrence-from-event-content-type

    No Code Solution (without Powershell and SharePoint Designer) to "hide Recurrence field" or "hide AllDayEvent field":

    1. go to list settings
    2. go to your event content type
    3. click on some field to edit
    4. the url will now look something like:https://xxx.sharepoint.com/sites/01/_layouts/15/ManageContentTypeField.aspx?ctype=0x0102005387B5A54CC55F43AF64A0B67EBB8CE2&List=a1b74248-bc1f-48ce-9bfd-02c7ab696931&Field=Category&Fid=%7B6df9bd52-550e-4a30-bc31-a4366832a87d%7D
    5. now remove the "Fid" Parameter and replace "Field" Parameter value with either "fRecurrence" or "fAllDayEvent"
    6. now you can edit the field and make it hidden so it won't appear in any form
    Wednesday, April 10, 2019 4:13 PM