Users can't open form because it requires domain permission level.


  • I have two forms that I uploaded from my computer in the Shared Document library.   My users can't open the forms because it gives the following error.

    "This form cannot be opened because it requires the domain permission level and it currently has restricted permission.  To fix this problem, open the form from the lcoation it was published to."

    I want multiple forms in the same library  so I didn't want to create a different library for every form.  Can I only publish one form per library?  I tried to publish one of the forms but it wouldn't publish because it gave me the following error:

    "Infopath failed to publish because the default content type in the document library is not based on the Form content type"

    Does anyone know what I need to do to get a library where I can publish several forms in the same library and have my users access those forms?

    • Moved by Paul Galvin Monday, October 13, 2008 10:31 PM Pretty sure this is an infopath question and answer. (Moved from SharePoint - General Question and Answers and Discussion to SharePoint - InfoPath Forms Services)
    Monday, October 13, 2008 6:50 PM

All replies

  • Hi Sandra,

    did you try to create a "Forms library" instead of a document library or change the default Content Type on the library to forms?

    Did you assign full trust from the form before publishing it to the site?

    Are you having any "external code" in the form?


    Daniel Bugday™ Web: © SharePoint Forum Blog: Daniel Bugday's Blog
    Monday, October 13, 2008 7:07 PM
  • I think I have it figured out.  I changed the default type to forms, published the form with full trust as a new content type instead of a document library.  It seems to be working, at least for one user.    

    I don't have any external code in the form. 

    Thank you for your help.  I'm still a newbie to all of this stuff.  It's all complicated.

    Monday, October 13, 2008 7:47 PM
  • Create a forms library.  When you want to publish more than one form to the library you need to publish it as a content type.  This enables you to see both forms listed in the library.
    Friday, September 11, 2009 6:25 PM
  • Hi

    I have the same error but using a different method.

    This form cannot be opened because it requires the domain permission level and it currently has restricted permission. to fix this problem, open the form from the location it was published to..

    Published location: file://c:\users\shahhl\documents\personal\inforpath single page form starting point.xsn

    i have create a new form in infopath and havent published it anyway. it is protected. when i send the template to other users they cant open it.

    please can you help me with this?

    Friday, February 19, 2010 4:13 PM
  • give the users access to the template folder
    Tuesday, March 02, 2010 9:02 PM
  • thanks,

    i have uploaded the template on sharepoint and then published that to a form library and gave the users access to that. all works fine now.

    • Proposed as answer by MGUK Thursday, April 08, 2010 2:24 PM
    • Unproposed as answer by Mike Walsh FIN Friday, April 09, 2010 4:18 AM
    • Proposed as answer by Tom Molskow Thursday, December 01, 2011 1:32 AM
    Thursday, April 08, 2010 2:24 PM
  • MGUK:

    Please don't propose your own posts as answers. It isn't helpful.

    Propose the good answers of other people but wait for someone else to propose your posts.




    FAQ sites: (SP 2010); (v3) and (WSS 2.0)
    Complete Book Lists (incl. foreign language) on each site.
    Friday, April 09, 2010 4:20 AM
  • Thanks MGUK for your post answer. Waiting on someone else might not ever come.


    Wednesday, July 27, 2011 2:35 PM