none
Infopath Property promotion rich text field truncated in sharepoint 2010 RRS feed

  • Question

  • Hi,

     

    I have an infopath 2010 form i am promotiong the properties to sharepoint list. but I am facing an issue the fileds only carry up 255 characters rest is truncated. Is there any way i can get it right?

    Thanks
    Chamy

     


    Chamy07
    Wednesday, December 1, 2010 4:09 PM

Answers

  • Yes, because when you promoted it, you let it create the field for you, and it always creates single line of text fields, which have a limit of 255 characters.  You need to make sure the field in SharePoint is a multi-line field.  I'm not sure if it works, but you can try to create the multi-line field in your form library first, then re-publish the form and promote that InfoPath field so that it connects to the existing multi-line column instead of letting it create its own new single-line column.  Before doing either, re-publish the form and remove this field from the property promotion so that it removes all references, then re-publish and promote to the existing column.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by Wayne Fan Thursday, December 9, 2010 2:14 AM
    Wednesday, December 1, 2010 6:37 PM

All replies

  • Yes, because when you promoted it, you let it create the field for you, and it always creates single line of text fields, which have a limit of 255 characters.  You need to make sure the field in SharePoint is a multi-line field.  I'm not sure if it works, but you can try to create the multi-line field in your form library first, then re-publish the form and promote that InfoPath field so that it connects to the existing multi-line column instead of letting it create its own new single-line column.  Before doing either, re-publish the form and remove this field from the property promotion so that it removes all references, then re-publish and promote to the existing column.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by Wayne Fan Thursday, December 9, 2010 2:14 AM
    Wednesday, December 1, 2010 6:37 PM
  • Thanks

    I will try your suggestion


    Chamy07
    Wednesday, December 1, 2010 8:18 PM
  • I tried this.  Both with a native SharePoint Form Library (created by InfoPath) in 2007 and 2010.  Turns out that as soon as you create a form library with InfoPath, SharePoint will not allow you to create a column that is rich text.  Create a different list and there is no issue creating a Rich Text Field.
    Monday, March 21, 2011 1:29 PM
  • I had this problem too. It was because I used a text field on the InfoPath form instead of a rich text field. When you promote the property, a text field maps to a single line of text field in the SharePoint library.  You can't change a text field to a rich text field in InfoPath so you have to delete the text field, add a rich text field, then promote the new field to the library.  


    Monday, March 28, 2011 2:44 PM
  • Very cool...thanks Clayton.  Worked perfectly.
    M
    Friday, December 16, 2011 2:44 PM
  • The following worked for me (only for multi-line 'not' rich text field) (InfoPath 2013:

    -          - Republish the form but select ‘allow edit’ when promoting the fields during the publishing wizard.

    -         -  This will allow us to change the column settings of the required fields.

    - -     -  In library settings, change the settings to support multi-line.

    - And here is the tricky part, when you try the publish the form again it is going to complain about the mismatch content-type. Go back to the publishing wizard, un-select the 'allow edit' for each field and publish the form again. It will not change the fields back to single line but it will only take away the option to edit the field through library settings.

    Good Luck!

    Friday, March 13, 2015 12:35 AM