none
Workflow status column not showing in List View RRS feed

  • Question

  • Hello,

    I created a reusable workflow based on OOTB Approval WF. I associated the WF to the content type in my list (and tried the list itself as well) and after I run it no workflow status column is created on the list. I checked the views for a column named after my workflow and no luck. Does anyone know how to get the workflow status column to appear? I thought it was supposed to be created automatically when the WF is first ran.

    Thank you. 


    Stephen
    Tuesday, September 6, 2011 2:15 AM

Answers

  • There is an easier way (assuming the workflow fires without errors): create a new column in the list/library with the required default value and update it from the workflow (use the update list item action).
    AK
    • Marked as answer by StephenEL1 Saturday, September 17, 2011 8:53 PM
    Saturday, September 17, 2011 6:31 AM

All replies

  • If you mean the Approval-SharePoint 2010 WF, it will not be available as a column (automatically in default view or by editing other views and adding the WF name) until at least one instance of the WF is started. Configuring and saving the WF is not enough to have the column available.
    AK
    • Proposed as answer by Thilosh V N Tuesday, September 6, 2011 7:20 AM
    Tuesday, September 6, 2011 6:16 AM
  • Understood, after I run the WF the column is still not created.
    Stephen
    Wednesday, September 7, 2011 10:57 PM
  • Can you log some text in the WF history and view it after the WF runs?
    AK
    Thursday, September 8, 2011 5:13 AM
  • I added history to the log and still no luck. Is there a way I can just pull in the workflow status for each item ID if I know the GUID of the workflow history list?
    Stephen
    Wednesday, September 14, 2011 2:08 AM
  • The history list is at http://site-url/Lists/Workflow%20History/AllItems.aspx
    You have a list GUID and item ID, but you can easily spot the logged data (or errors) under [Description] which accepts sorting and filtering.
    AK
    Wednesday, September 14, 2011 10:50 AM
  • Is there a way to create a workflow status column manually and populate it using jQuery or something else? I just need a work-around for now.


    Stephen
    Saturday, September 17, 2011 2:28 AM
  • There is an easier way (assuming the workflow fires without errors): create a new column in the list/library with the required default value and update it from the workflow (use the update list item action).
    AK
    • Marked as answer by StephenEL1 Saturday, September 17, 2011 8:53 PM
    Saturday, September 17, 2011 6:31 AM