none
Empty Usage and Helth data report RRS feed

  • Question

  • Hello All ,

    New share point 2013 Developer  with his question here please help.....

    i have configured usage and health data from central Admin >> Monitoring >> Configuring health data collection.  Enable usage data collection and health data collection  check boxes is checked.

    i want to show Site collection usage Report so i go to site collection >> Site settings>>Popularity trend  and download usage xlsx file . but it is empty . tried from several place but could not get success . 

    Please suggest me what to do next . to view report . is it possible to see Report graph on the site itself rather than downloading in xslx file.

    very  thanks in Advance .



    Thursday, January 31, 2013 8:19 AM

Answers

  • Hi all ,

    Thanks for Replying .

    my Problem has been solved . i have created a login in sql Server and given db_owner permission for the database Wss_logging.

    from CA>>monitoring >> configure usage and helth data i have used sql Auth rather than windows . it solves my proublem .

    any way thanks
    • Marked as answer by Mukesh Tripati Tuesday, February 12, 2013 11:28 AM
    Tuesday, February 12, 2013 11:28 AM

All replies

  • Hi,

    when you configure setting, how many hours have been passed.

    Usage data is initially stored in Usage Log file (.USAGE ) on SharePoint Server under logging directory which is later processed by Microsoft SharePoint Foundation Usage Data Import Timer job that runs every 30 min into Usage Database.

    There is another timer job Microsoft SharePoint Foundation Usage Data Processing, this job checks for expired usage data at the farm level and deletes data.
    Expired usage data consists of records in the central usage data collection database that are older than 30 days.

    Reports you can also viewed form central admin. Below is reference link from SharePoint 2010 which might help you out for SharePoint 2013.

    http://blogs.technet.com/b/sharepoint_quick_reads/archive/2012/02/20/sharepoint-2010-usage-and-health-service.aspx

    thx


    iffi

    Thursday, January 31, 2013 9:52 AM
  • Hello Imughal,

    Thanks for reply . i have read the article . very first thing my Usage and Health data collection

    service is up and running. i am new and could not understand much.

    i decided to see timer jobs as suggested by you . Microsoft SharePoint Foundation Usage Data Import Timer job

    and Microsoft SharePoint Foundation Usage Data Processing, but can not find .

    one other thing i have configured search and it is working for me . i can see reports related to search and query . i want to see page visitors . no of visits , unique visits etc.

    i brows to Site collection >> site settings >> Popularity Trend from site administration it is blank while search reports are  showing data.

    as per your suggestion i tried to see usage log file located at hive/logs/pagerequests but several things are writen could not understand .

    now please help me what to do..

    Friday, February 1, 2013 7:20 AM
  • Hi,

    For i want to see page visitors . no of visits , unique visits etc  have you configure Web Analytic Service Application if not configure it and wait for 24 hrs to see data in reports.

    thx


    iffi

    Friday, February 1, 2013 7:29 AM
  • Thanks for Reply . i will check it and tell you very soon.
    Friday, February 1, 2013 8:13 AM
  • Hello ,

    Where  is web Analytic s Service Applecation in share point 2013 . when not found i checked this link.

    http://blog.octavie.nl/index.php/2012/07/09/sharepoint-2013-its-here/

    it says web analytics  application has been gone have all things are included in to search.

    Hellooo some one help me. 

    • Edited by Mukesh Tripati Friday, February 8, 2013 8:15 AM could not get any reply
    Friday, February 1, 2013 8:16 AM
  • helloooooooooooooo

    any one is there please help me i am in trouble..

    Monday, February 11, 2013 4:36 AM
  • Hi,

    have you configured search.In SharePoint 2013 web analytics is merged with search service, have your configured search service and done full crawl.

    To get to the Usage Reports in SharePoint 2013
    http://www.techbubbles.com/sharepoint-2013/analytics-features-in-sharepoint-2013/

    discontinued or changed in SharePoint 2013

    http://office.microsoft.com/en-us/sharepoint-help/discontinued-features-and-modified-functionality-in-microsoft-sharepoint-2013-HA102892827.aspx

    thx


    iffi

    Monday, February 11, 2013 9:52 AM
  • Hi Imughal ,

    very thanks for reply . i was waiting for you since several days.. situation is bellow ..

    my search is working fine . crawling is continuous.

    from CA>>monitoring>> configure health data collection. respective check boxes is enabled . but data is not showing in usage reports from site settings >> popularity trends.

    timer jobs Microsoft share point foundation usage data import timer job and Processing timer job is up and running.

    accounts WSS_admin_wpg and WSS_wpg have full privilege in log folder.

    while troubleshooting the above problem i tried to see the data in database WSS_Logging  in following tables.

    ImportUsage_Partition0,1,2,3 etc but these tables are empty . similarly exportusage tabels are also empty.

    Ok in log file data is going . i have seen it.

    why data is not writing  in logging database . sql login which is used have db_owner role . for that purpose .

    please help me . any reply is highly appreciated.......

    if you can suggest how to trouble shoot above problem i will be highly thankful to you ..

    Monday, February 11, 2013 10:04 AM
  • hellooooooooooooooo, any one there..
    Monday, February 11, 2013 12:33 PM
  • Hi all ,

    Thanks for Replying .

    my Problem has been solved . i have created a login in sql Server and given db_owner permission for the database Wss_logging.

    from CA>>monitoring >> configure usage and helth data i have used sql Auth rather than windows . it solves my proublem .

    any way thanks
    • Marked as answer by Mukesh Tripati Tuesday, February 12, 2013 11:28 AM
    Tuesday, February 12, 2013 11:28 AM
  • That's strange, im having the same problem as well.

    Btw, which account are you using? for the SQL.

    web 80 app pool service account>?


    Cheng

    Thursday, July 18, 2013 1:06 PM
  • Hello Cheng,

    Several Days have been gone since i have done above work. but if your usage and health data is empty then

    you should check bellow two things.

    1) there is a timer job which copies the data from log to database see job is running successfully . see WSS_admin and WSS_wpg groups have permissions on the Analytics and usage data related folders in log.

    2)the account which is used for usage and helth data should have permission on sql server database.

    you can not see usage and health data immediately . i needs at least one day.


    Mukesh

    Friday, July 19, 2013 4:22 AM
  • Hello

    When I go to configure this I put my SQL Auth login and password, hit OK and everything looks fine but when I go back to the page I see it's gone back to Windows?

    Is this expected?

    Monday, September 9, 2013 6:27 PM