none
Open Infopath form in a browser when click New Item on Forms Library RRS feed

  • Question

  • I have created a Forms Library which I have associated with a infopath Form, when I click new I always want that form to open in a Browser..
    Tuesday, January 19, 2010 3:16 PM

Answers

  • Also, there is a check box that you must select during publishing at the point where you decide to publish to a doc lib, content type, or central admin.  Be sure to check the box at the top for browser-enabling the template.
    SharePoint Architect || My Blog
    Tuesday, January 19, 2010 11:50 PM
  • When you are creating a Infopath form make sure you tick the Enable browser enabled features only at the time when you are creating a new infopath form. Make sure that your form is browser enabled (Tools -> Form Options -> Compatibility) in InfoPath. The "Design a form that can be opened in the browser" is checked and selected. After designing your form publish it in your Sharepoint Forms Library.

    After that follow this step:
    1. Go to the Form Library to which you published the InfoPath form template.
    2. Click Settings on the Form Library menu bar and choose Form Library Settings from the drop-down menu.
    3. On the Customize <Form Library Name> page under the General Settings category, click Advanced settings .
    4. On the Form Library Advanced Settings: <Form Library Name> page under the Browser-enabled Documents category, choose Display as a Web page .
    from the Central Administration also make sure to enable this feature.

    To enable this setting:

    1. Open SharePoint Central Administration .
    2. Click the Application Management tab.
    3. On the Application Management page under the InfoPath Forms Services category, click Configure InfoPath Forms Services .
    4. On the Configure InfoPath Forms Services page under the User Browser-enabled Form Templates category, check Render form templates that are browser-enabled by users .

    once you followed above steps, you can get the infopath form loaded in a new browser window when you click the new button.
    Tuesday, January 19, 2010 4:17 PM

All replies

  • When you are creating a Infopath form make sure you tick the Enable browser enabled features only at the time when you are creating a new infopath form. Make sure that your form is browser enabled (Tools -> Form Options -> Compatibility) in InfoPath. The "Design a form that can be opened in the browser" is checked and selected. After designing your form publish it in your Sharepoint Forms Library.

    After that follow this step:
    1. Go to the Form Library to which you published the InfoPath form template.
    2. Click Settings on the Form Library menu bar and choose Form Library Settings from the drop-down menu.
    3. On the Customize <Form Library Name> page under the General Settings category, click Advanced settings .
    4. On the Form Library Advanced Settings: <Form Library Name> page under the Browser-enabled Documents category, choose Display as a Web page .
    from the Central Administration also make sure to enable this feature.

    To enable this setting:

    1. Open SharePoint Central Administration .
    2. Click the Application Management tab.
    3. On the Application Management page under the InfoPath Forms Services category, click Configure InfoPath Forms Services .
    4. On the Configure InfoPath Forms Services page under the User Browser-enabled Form Templates category, check Render form templates that are browser-enabled by users .

    once you followed above steps, you can get the infopath form loaded in a new browser window when you click the new button.
    Tuesday, January 19, 2010 4:17 PM
  • ammarcool:

    Do not propose your own posts as answers. It isn't helpful.

    Propose the good answers of *other people* - that is helpful - but not your own.


    (Moderator)


    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    • Proposed as answer by Rajni Kaushal Thursday, February 20, 2014 11:07 AM
    Tuesday, January 19, 2010 5:26 PM
  • Also, there is a check box that you must select during publishing at the point where you decide to publish to a doc lib, content type, or central admin.  Be sure to check the box at the top for browser-enabling the template.
    SharePoint Architect || My Blog
    Tuesday, January 19, 2010 11:50 PM
  • Hi

    I have tried all these suggestions and when I click the "Edit Document" button on the ribbon it still opens in infopath??

    If I click on the "Name" column which is linked it opens in the browser.

    This is quite annoying because all the settings (on the library, in infopath and on the admin server) say "open in browser".

    Can anyone tell me how to fix this? 

    Wednesday, March 2, 2011 4:31 AM
  • Ensure you have the "SharePoint Server Enterprise Site Collection features" feature activated in your site collection features for the site collection.

    After this you will need to re-publish, checking the "Enable this form to be filled out by using a browser" checkbox.

    • Edited by Mereel Friday, May 11, 2012 12:17 AM
    Friday, May 11, 2012 12:08 AM
  • Hi,

    I have a borwser-enabled forms published as content types, I`ve deleted default content type Form from form library, I checked "Display in browser" property in library`s advanced settings and still got this issue: form is displayed in browser for users, that do not have Infopath Filler installed, and Infopath filler loads for users, that have Infopath Filler installed. And one more thing: I have Infopath Filler installed and forms are displayed in browser for me!

    Maybe something somewhere cashed?

    Tuesday, September 18, 2012 2:37 AM
  • I know in IE8 (and I think 7 too) there's a script setting in the security level of Internet Options that when disabled a browser form opens as a filler form.  I won't be able to test it out until tomorrow to let you know which setting it is.  It seems that in IE9 even when the setting is disabled the form still opens in the browser.
    Tuesday, September 18, 2012 8:54 PM
  • I tried all the above options but still i am not able to open the infopath form in browser

    Monday, October 14, 2013 5:25 AM
  • The answer marked isn't the answer to the question - I am having this problem as well. I may have to do a work around if there is no other option. 

    My chosen work around is to either A. Go in to SharePoint designer and change the edit document function to open view one in my form or B. When my users receive emails give them a direct link to the name column so that their form will be opened in a browser and they never have to interact with the site.

    I hope this is helpful

    Thursday, November 7, 2013 1:03 PM