none
SharePoint Work Flow designer - Send-email action canceled work flow RRS feed

  • Question

  • Hello, 

    •   I have create a simple SharePoint 2013 workflow  by SharePoint designer . 
    •   The workflow has "Send Email" action .
    •   I have add new item in list and run the workflow .  the workflow canceled automatically .

    •   I have Create another workflow "SharePoint 2010 workflow" by SharePoint designer .
    •   I repeat the previous steps . The Email sent successfully. 

          So why send Email action is working with SharePoint and not working with SharePoint ?

       here it is the exception that I get when the workflow is canceled 

        RequestorId: e19b955f-f426-5911-98ca-99a468c60325. Details: System.ApplicationException: HTTP 500 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["45"],"SPRequestGuid":["e19b955f-f426-5911-98ca-99a468c60325"],"request-id":["e19b955f-f426-5911-98ca-99a468c60325"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Sun, 26 Oct 2014 18:42:40 GMT"],"Server":["Microsoft-IIS\/8.5"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager,  

    RequestorId: e19b955f-f426-5911-98ca-99a468c60325. Details: System.ApplicationException: HTTP 500 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["45"],"SPRequestGuid":["e19b955f-f426-5911-98ca-99a468c60325"],"request-id":["e19b955f-f426-5911-98ca-99a468c60325"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Sun, 26 Oct 2014 18:42:40 GMT"],"Server":["Microsoft-IIS\/8.5"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, 
    RequestorId: e19b955f-f426-5911-98ca-99a468c60325. Details: System.ApplicationException: HTTP 500 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["45"],"SPRequestGuid":["e19b955f-f426-5911-98ca-99a468c60325"],"request-id":["e19b955f-f426-5911-98ca-99a468c60325"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Sun, 26 Oct 2014 18:42:40 GMT"],"Server":["Microsoft-IIS\/8.5"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, 

    ASk

    Sunday, October 26, 2014 5:51 PM

Answers

  • Hi himo,

    For a better troubleshooting, I suggest you can try as the followings:

    1. Check outgoing email settings for the farm are correct.

    2. Disabled firewall on the Exchange/SMTP server.

    3. Check App management service is running, UPA is set up and  completed sync such that the user running the workflow has a profile.

    Here is a detailed article for your reference:

    http://anujabhojani.blogspot.jp/2014/02/workflow-gets-canceled-automatically.html

    Best Regards

    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Zhengyu Guo
    TechNet Community Support

    Thursday, October 30, 2014 10:21 AM
  • Hi Greetings.

    pls check this

    http://blogs.technet.com/b/meamcs/archive/2011/09/23/sharepoint-workflow-error-workflow-is-automatically-cancelled.aspx

    http://sharepoint.stackexchange.com/questions/83230/workflow-canceled-automatically


    Please remember to click 'Mark as Answer' on the answer if it helps you

    Monday, October 27, 2014 5:57 AM

All replies

  • Hi Greetings.

    pls check this

    http://blogs.technet.com/b/meamcs/archive/2011/09/23/sharepoint-workflow-error-workflow-is-automatically-cancelled.aspx

    http://sharepoint.stackexchange.com/questions/83230/workflow-canceled-automatically


    Please remember to click 'Mark as Answer' on the answer if it helps you

    Monday, October 27, 2014 5:57 AM
  • Hi himo,

    For a better troubleshooting, I suggest you can try as the followings:

    1. Check outgoing email settings for the farm are correct.

    2. Disabled firewall on the Exchange/SMTP server.

    3. Check App management service is running, UPA is set up and  completed sync such that the user running the workflow has a profile.

    Here is a detailed article for your reference:

    http://anujabhojani.blogspot.jp/2014/02/workflow-gets-canceled-automatically.html

    Best Regards

    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Zhengyu Guo
    TechNet Community Support

    Thursday, October 30, 2014 10:21 AM