Datasheet Error 0x80070057


  • Hello,

    I ran intro an error when editing a custom list using the datasheet view. The error occurs when a "person or group" field is edited. Right after the user clicks on another cell after entering data in the person column, IE pops up an alert window with:

    Windows Internet Explorer
    An error 0x80070057 occurred.  No further information was provided.

    One thing that I noticed is that the cell is rendered as a combo box, and when the drop down is clicked there are no choices. The choices are typically populated with the sharepoint groups and users of the site.

    The site has been customized with a custom master page.

    I have turned logging to verbose and I can not find any relevant entries in the WSS logs.

    Has anyone run into this and know how to resolve it?


    Alonso Robles

    Friday, August 08, 2008 11:36 PM


All replies

  • Hello Alonso,

    Do you have the web.config file set to provide stack trace and debug information? (I mean error reporting on for SharePoint).

    Quick Reference:

    If you do and that is all the information it provides please let me know (also is this an alert box that pops up?),
    Monday, August 11, 2008 6:40 PM
  • I'm also getting this error in the exact same scenario (almost word for word), although I have not modified the master page.  I do have my web.config set to provide stack trace and debug information, but the error occurs in a javascript popup.  There is no more information.  This view used to work, but I'm not sure what changed to break it.
    My blog:
    Friday, August 14, 2009 7:31 PM
  • Ok, solved it.  In my case the problem was because I didn't specify List="UserInfo" in my fields.xml file.  Try updating your CAML to something like this:

        Group="My Fields"
        DisplayName="My User"

    For more detail there's an example here:
    And of course the Field element CAML documentation:

    My blog:
    • Proposed as answer by Lee Richardson Friday, August 14, 2009 8:23 PM
    Friday, August 14, 2009 8:23 PM
  • Alternatively - at least this worked for me on SharePoint Online (Office 365):

    1. Open the list in SharePoint designer
    2. Modify the "Person or Group" column causing the problem. (I noticed at this point that the selected options/settings for this column were not what I originally chose when creating/editing this column in the browser)
    3. Make at least one change and save.

    Now the column should behave as expected.

    • Proposed as answer by Gavin11 Friday, August 24, 2012 8:40 AM
    • Edited by Gavin11 Friday, August 24, 2012 8:50 AM
    Friday, August 24, 2012 8:39 AM
  • I encoutnered this problem on a 2010 SharePoint Site that was set up as a publishing site using a custom masterpage. This was encountered using Datasheet view in a custom list.

    I found the following was the cause of the error.

    The Custom List was created using custom site columns which I created in SharePoint Designer. When a person or group field is created in the Site Column Directory, it will automatically default to the folllowing settings:


    Show Field: Account

    Allow Selection of: People or Groups

    Choose from: Sharepoint Group: [Will automatically populate the first permission group in alpabetical descending order, e.g. 123Group]

    Allow Blank Values: Yes

    Allow Multiple Value: No


    To resolve the issue, the Site Owner or Designer must edit each of the site columns to:


    Show Field: Name / or desired field format

    Allow Selection of: People Only <--

    Choose from: All Users <--

    Allow Blank Values: Yes

    Allow Multiple Value: No


    Make sure you check you list columns match these settings or you could push the changes to all list if using Sharepoint Designer.

    This resolved the issue for me. 

    Tuesday, December 29, 2015 4:51 PM
  • I found this worked for me, had to be done in Sharepoint designer though in the list, and column setting for that list.

    Changing the Allow Blank Values, did the trick.

    Sunday, September 04, 2016 2:13 AM