none
Office 365 : SharePoint designer workflow platform not available RRS feed

  • Question

  • Hi,

    We have Office 365 E3 subscription and I am facing issue creating any SP2013 designer workflow for the sites created via Custom Web Templates ?

    The option to create designer workflow with "SharePoint 2013 Workflow platform" is unavailable with message..

    "The option for SharePoint 2013 Workflow platform is not available because the workflow service is not configured on the server, please contact your server administrator"

    To add to the issue even if we create 2010 designer workflow, the workflow does not get associated with the list/library. I can see the workflow in SharePoint designer but not with library settings from the browser and of course the workflow is not executed.

    Can anyone please suggest any solution ?

    Thanks in advance.

    Rajesh

    • Changed type JasonGuo Friday, August 22, 2014 2:42 AM
    Tuesday, August 12, 2014 12:07 PM

All replies

  • Hi,

    If you are a tenant administrator please log into your admin account

    navigate to this  "https://youraccount-admin.sharepoint.com/_layouts/15/online/TenantSettings.aspx"

    In this page,under connected services, deselect the "Block SharePoint 2013 workflows".


    Murugesa Pandian.,SharePoint 2010, MCPD | MCTS - Configure


    • Edited by Murugesa Pandian Tuesday, August 12, 2014 2:25 PM
    • Marked as answer by JasonGuo Friday, August 22, 2014 2:42 AM
    • Unmarked as answer by rajesh vartak Monday, September 1, 2014 9:28 AM
    Tuesday, August 12, 2014 2:25 PM
  • Hi Murugessa,

    Thanks for your reply but i have verified and "Block SharePoint 2013 workflows" is unchecked. Looks like it's something else.

    Regards,

    Rajesh

    Monday, September 1, 2014 9:28 AM
  • Bumping this. Anyone having any luck with this? 
    Tuesday, May 26, 2015 3:55 PM
  • I have the same problem, any pointers would help.
    Thursday, June 4, 2015 4:03 PM
  • from: https://community.office365.com/en-us/f/148/t/319358

    You need to go into Workflow Settings on the site.

    Then click Workflow Health (a very subtle link!).

    Then click Activate.



    • Edited by 8Fergus24 Saturday, June 6, 2015 6:06 PM convert link to link
    • Proposed as answer by 8Fergus24 Saturday, June 6, 2015 6:06 PM
    Saturday, June 6, 2015 6:05 PM
  • Thanks, that worked like a charm!

    So just to clarify, the steps are:

    1. Go to: Site settings > Workflow settings
    2. At the you see the title "Werkstromen  (Workflow Health)"
      (Workflow Health is called Werkstroomstatus if you happen to be on a Dutch SharePoint version)
    3. Now click on Workflow Health (it's subtle indeed, but it's really a link)
    4. On the next screen with the status per workflow, there will be a message that something is not activated, including an "Activate" button.
    5. Click that "Activate" button, wait for 5 minutes (almost nothing is instantaneous on Office 365) and you're good to go.
    Friday, February 10, 2017 10:28 AM
  • Thanks for all the information!

    I have a similar issue (O365 E3 - Trial) -> Can't uncheck "Block SharePoint 2013 Workflows"

    I uncheck this option, save it and after returning to settings, it is checked again.

    Here is a post about the same problem, but it's from 2014.

    Any advice how to resolve this?

    Thanks in advance!


    Saturday, February 11, 2017 7:59 PM