How do I add categories to Wiki pages?


  • I have sharepoint 2010 and I need to add categories to my wiki pages.

    The problem is that the category field is greyed out and clicking the tags icon next to it does nothing (nothing opens, no error messages).

    I know this is looked after by the managed metadata and I have access to this and I can add/create/remove terms and groups. But for the life of me, I can't get the categories to open up and be usable. And I can't find any info on troubleshooting this.

    Can anyone help? I could be doing something stupid so forgive me if this is a dumb question.

    Monday, September 13, 2010 5:02 AM


All replies

  • You might need to go to the library settings and make sure it is enabled for keywords. Try the Enterprise Metadata and Keywords link.
    Monday, September 13, 2010 5:45 AM
  • Thanks, I tried that. Enabled both options but still no happiness :(
    Monday, September 13, 2010 5:55 AM
  • Did you go the column [wiki categories] and then select the term set that you would like to use? It remains grayed out until you select some term set to start with :)

    Alpesh Nakar's Blog Alpesh Just SharePoint Just SharePoint Updates

    SharePoint Conference Southeast Asia Oct 26-27 2010 Contributing Author SharePoint 2010 Unleashed

    MCTS: SharePoint 2010 Configuration MCITP: SharePoint 2010 Administrator

    • Marked as answer by Idlegamer Monday, September 13, 2010 10:40 PM
    Monday, September 13, 2010 10:14 AM
  • Thank you! Thank you! That did the trick. :)
    Monday, September 13, 2010 10:42 PM
  • For the life of my I can't configure this setting.  It worked once and then I deleted and recreated my site colelction...from this point forward, I couldn't add a wiki catagory andthe field is greyed out...cannto figure out what buttons to puch to make this work :(  Again first time it worked with minimal setup now it doesn't.
    Tuesday, December 14, 2010 7:19 PM
  • Hi,


    I have been struggling with this - can't seem to get it going. As others have mentioned on this forum, it was working with almost no effort before and it suddenly stopped working along the way. I have changed the view and edited the properties so that I can key in the categories but its disabled. I also clicked on the little tag (for browsing) and nothing happens. 


    I have also enabled Enterprise Metadata and no cigar :-(



    Monday, December 20, 2010 12:35 PM
  • Under the term sets - my radio button is grayed out and "User a managed term set" is selected. Then there is a text box asking me to select a term set with a search icon next to it...when I search for anything, nothing comes up. Below it is a text area and it says "Managed Metadata Service" display...clicking that doesn't bring up anything either. 


    What is it that I am missing :-(

    Monday, December 20, 2010 12:54 PM
  • Eventually discovered:  To add a category, go to your All Pages view.  Click Settings - Document Library Settings and, under Columns, Category.  Add your new category to the "Type each choice on a separate line" box. 


    SharePoint Services 3.0.

    Monday, May 09, 2011 7:54 PM