none
Infopath Save Error RRS feed

  • Question

  • I have an infopath form with mutliple views.  The approval view is giving me grief as I'll try to explain.  My user can add items to the Sharepoint list using a view within the infopath form.  That same user, as well as all others, can't update the item on the same list using a different view in the form.  Why?  The error says permission or read-only problems but the user does have contribute rights to the list and security to the item itself.  This is all in SP 2010.

    The form cannot be submitted.
    The form cannot be submitted to the specified SharePoint list or document library. The SharePoint location may be read-only or you may not have permissions to access it.

    An entry has been added to the Windows event log of the server.

    Log ID:5567

    Tuesday, July 10, 2012 7:29 PM

Answers

All replies

  • Hi KHNSteve,

    Error 5567 tells us that we unable to update (or create) data in SharePoint list. For example, if there is field (like document Name field) marked as “Enforce unique values”, then you are update a field to a value already exists in the column in other item, it will stop use the submit the data.

    After check this, if the problem still persists, could you tell us how you design the form view you use to update list items?

    Thanks & Regards,
    Emir


    Emir Liu

    TechNet Community Support

    Wednesday, July 11, 2012 10:52 AM
  • None of my columns have "Enforce unique values" on them.  I checked twice to make sure.

    As for designing the form I simply used Infopath and created a view with the fields on it that I need to update.  It's an approval type form so the top half is filled in with the data from the list and the bottom half the user would click, for example, "Yes or no I approve" etc.


    I think it's some sort of security issue.  I have really high level security on the site since I'm a developer and I can approve the items with no problem.  No one else can even though they have contribute, limited access rights to the list and contribute rights to the item itself.  I don't understand why it won't work with those securities.
    • Edited by KHNSteve Wednesday, July 11, 2012 12:41 PM
    Wednesday, July 11, 2012 12:08 PM
  • Whether you have deployed the form in central admin or directly to site library?

    If you deployed the form in central admin, then make sure the form template is activated to the particular site collections.


    Senthil

    Wednesday, July 11, 2012 4:14 PM
  • The form should be on the site.  I was on the list and clicked the Customize Form button which opens infopath. 

    We've been trying this more today.  With the same permissions users can Add items to the list but not update the items...using the form.  Just doesn't make sense.

    Wednesday, July 11, 2012 4:48 PM
  • Let me know what are the datatype used in that form. Beucase infopath form doesn't support all the sharepoint data type. Make sure the forms design doesn't through any errors.


    Senthil

    Thursday, July 12, 2012 3:36 AM
  • Infopath hasn't thrown any errors.  Datatypes on the list are: choice, date and time, number, mulitple and single line of text.  On the approval form there is no person/group datatype even though those exist on the list.  We are still stumped.  It seems if the approving user has Manage Lists rights we don't get the error BUT we don't want them to manage the list.  That means they can also delete the list...very bad.

    Thursday, July 12, 2012 3:06 PM
  • It seems that any of my sites that use infopath that also need an approval or a save back to a list have security errors.  Anyone have any thoughts?  I'm now up to three sites that have security problems through infopath.
    Monday, July 30, 2012 12:39 PM
  • No resolution found.
    • Marked as answer by KHNSteve Thursday, August 30, 2012 12:24 PM
    Thursday, August 30, 2012 12:24 PM
  • Hi There!

    Replying to this old post, as this is the exact issue I was having and after stuggling and googling for several hours, found my unique situation and resolution. Might help all who have similar issue.

    In my case, as site admin, I was able to submit InfoPath forms, but normal users were getting the error as described in the post by KHNSteve.

    Similar issue can come up if you have restricted who can edit the list items through List Settings > Advanced option. (e.g. all can read but only creator can edit). But in my case this was not the issue, all users could read and edit all items. Other causes include, rules defined in Submit button and incorrect permissions (rare possibility). Not in my case.

    Interestingly, if I reverted to SharePoint Form instead of InfoPath form, the issue was not there. However, now I understand that this is because SharePoint and InfoPath forms have a fundamental difference: SharePoint forms update only the "changed" values in a record while InfoPath forms update all the fields in the record, regardless of whether the field was changed or not by the user. So? The result is that - if any of the values in the record break integrity due to any issue, the InfoPath form will not submit while SharePoint form will work as long as the field that breaks integrity is not changed.

    Access also behaves in a similar way as InfoPath. So I recommend, you try to update a field in list linked to Access and check if it works. Access error will tell you which field has an issue if any. If it works fine in Access, the issue is not related to data integrity but most probably with permissions required to successfully create and validate all fields in a record.

    Getting to my scenario, let me explain how my list was organized for appropriate access.

    The list I have is a list of items with 3 levels of access - creators, managers, heads. For appropriate access, I created three columns in my list - creator, manager, head and 3 groups in my list permission - creators, managers, heads. Now, I restricted the selection for each of the column - creator column can have a person from creators group, manager from managers group, and head from heads group. So far so good. I tested with a user configured as a creator, manager and the items showed up correctly based on the filter criteria I gave. I designed InfoPath forms to hide all the internal fields. As site admin, I could submit the forms and thought everything is fine, till I found that user is not able to submit. I was clueless and tried lot of stuff including different combination of permissions, deletion of lookup columns, permission on lookup tables etc. Finally I was trying removing unique permissions for the site and list and make it simple inheritance. At that time it struck me.

    Every group has a setting that defines who can read the list of members of that group. Now, if InfoPath is updating every field, it will update creator, manager, and head field also and to validate that it is necessary that the logged in user has permission to read group membership. I had set the visibility of some groups to owner only that prevented validation of these columns and thus InfoPath form failed.

    When I changed the visibility of group to everyone, life became beautiful again :), it was a Eureka! moement:)

    Hoping this is helpful to someone stuck and panicking like me!

    Kind Regards, Uttam


    Technical Artist


    Thursday, June 9, 2016 7:23 PM
  • I was having this same error and this was exactly the issue that was causing it.  Thanks for the detailed description. 
    Wednesday, June 28, 2017 8:10 PM