none
Workflow attached to content type shows the status as 'Starting' RRS feed

  • Question

  • Hi,

    I have developed a workflow to distribute documents from Drop Off library to different SharePoint libraries based on the content type that the document uploaded to.

    The drop off library has been configured incoming mail settings hence the documents would be on boarded to drop off library through e-mails. In this scenario, my workflow should be triggered when the document is on boarded through email.

    Another scenario, the user can upload the document to different content type manually and updates the respective meta data values. This scenario, my workflow should be triggered when the item updated.

    So, I have configured my workflow should run on the content types and trigger when item is created through e-mail and item is updated by manual.

    The document on boarded through e-mails are working fine as soon as the item is created.

    Issue:

    The workflow associated on a content type which needs to be triggered on item created is triggering as soon as the user uploads a document manually and shows the status as 'Starting'.

    The workflow associated on a content type which needs to be triggered on item modified is triggering as soon as the user updating meta data values after document is uploaded. Hence, throwing an error 'cannot open a file from drop off' library exception when I try to read file using C# code as file stream bytes.

    Configuration:

    1. The content types are having mandatory fields which has a default values set.

    2. The document version settings are set as check out the document when editing the properties.

    Please help me to resolve this bug and let me know if you need more details.

    Also, let me know how can we cancel the workflow if it is in 'starting' mode.

    The workflow should run the document is onboardedwhen an item is created and

    Saturday, October 11, 2014 2:24 PM