Unable to delete groups in SharePoint Foundation 2010


  • I have a test group I created in SharePoint that I want to delete (I'm the only user in the group). In the "People and Groups: All Groups" screen I click the edit icon next to the group and then click on the "Delete" button and ok the following warning dialog. However, the group doesn't get deleted. Any idea why this is happening and how to finally delete this group? Thanks.
    Friday, September 24, 2010 2:56 PM

All replies

  • try removing all users from the group then delete.
    Wali Systems Inc. ( Hire certified virtual SharePoint assistants/developers!
    Tuesday, September 28, 2010 5:46 AM
  • What's the wanning text?

    SharePoint Zealot
    Tuesday, September 28, 2010 6:07 AM
    1. Go to Site Actions -> Site Settings -> People and Groups
    2. Click on the group and check all the users -> Actions -> Remove Users from Group
    3. Click on Settings -> Group Settings -> then click delete at the bottom of the page
    Thursday, November 04, 2010 2:48 AM
  • What is the warning? Maybe I can help you. Basically, we just need to go to people and group and remove the group. Then, add back it again. Or ask your provider to solve your problem. I have no problm with delete and add user.
    Thursday, November 04, 2010 5:05 AM
  • Same problem here. I created a site with visitors, members & owners groups. Deleted the site via the Content & Structure view - the 3 groups remain.

    Navigate to People & Groups and select the edit icon for the group I want to delete. Then the 'Delete' button.

    Prompt = 'Are you sure you want to delete this SharePoint Group'. OK.

    No warnings or errors, group remains in the list. Happens regardless of whether the group has any members. Besides groups shouldn't have to be empty to be deleted.

    Sunday, November 14, 2010 11:08 PM
  • Here the same problem,

    We have several SP2010 farms. 2 installed from scratch with powershell and 1 with the standard GUI installation.

    The one with the standard installation has no problems with removing sharepoint security groups. The 2 other installed with powershell cannot remove sharepoint groups.

    It’s only in the central admin application!

    The only difference that I see is that under Central administration->Manage web applications-> sharepoint Central Administration v4->Authentication Providers->’Default’ zone
    the option ‘Require Use Remote Interfaces permission’ is enabled. In the working farm is this option disabled.


    I cannot disable this option.

    Any suggestions?







    Friday, December 03, 2010 1:39 PM
  • I had a similar problem, created a "test", group, and i couldn't delete it afterwards (even when all members were removed).

    I managed to remove them using Sharepoint powershell


    $spWeb = Get-SPWeb "http://my-sharepoint-site"
    $spGroups = $spWeb.SiteGroups
    $spGroups.Remove("name of the group")

    After these commands, the group was gone.
    Hope this helps you.

    Harald Hoffelinck (

    Friday, December 10, 2010 7:13 PM
  • Found my problem..


    When you install a new farm with your own credentials, you are automatically Site Collection administrator of the Central administration application.

    Because I had installed my farm (with Powershell) with another ‘installation’ account, then that ‘installation’ account was Site Collection administrator.


    After I put my own account to the Site Collection administrator group, I could remove the SharePoint group without any problems.

    I was a little confused because when I want to delete that SharePoint group without the necessary permissions, you don’t get any warning or error message.




    Tuesday, December 14, 2010 3:48 PM
  • Yes, This is because of the permission. I was having the same issue... not being able to delete groups i created. Even if i was site coll admin it wasn't getting deleted. I had minimal site coll admin privilege (eg. i can't activate features"). Once i was given full permission i was able to delete.
    Monday, April 25, 2011 8:20 PM
  • Hi

    I am having the same problem. Looking at the last post it is not quite clear to me what you have done to solve this problem, whether you have changed the permision on sharepoint or the server itself.


    So far I have tried both (the sharepoint and the server) with no luck.


    I would greatly appriciate any help on this.


    Wednesday, September 28, 2011 9:22 AM
  • Hi,

    I also faced the issue but was not able to delete the group from the site itselft, whereas when i tried the power shell scripts described above the group gone away.

    $spWeb = Get-SPWeb "http://my-sharepoint-site"

    $spGroups = $spWeb.SiteGroups

    $spGroups.Remove("name of the group")


    But want to know if this can be done by the site itseft ? Why it is not possible with the site. I also tried visiting the site settings > Groups (_layouts/groups.aspx) page, but without success. :(

    Any help will be greatly appreciated.


    Deepak Semwal

    Answer to your Question on technet.

    Thursday, April 05, 2012 5:47 AM
  • Hi all,

    I had same problem and solution was to logon to Sharepoint as Farm Administrator. No problems with deleting groups after that.


    Thursday, August 02, 2012 2:13 PM