none
Word plug-in Hosting Ie - To help protect your security, your web browser has restricted this file from showing active content... RRS feed

  • Question

  • hello,

    At the company that I am working we have a Word Add-in that creates a ribbon of buttons and then hostes an IE browser over on the left pane of Word (This is an issue for both Word 2010 and 2013).  Our system is configured to have the browser bring up a file that is local on the pc that it is running on but then that file may be communicating with one of our back end servers.

    When we attempt to activate some functionality in the ie window (both ie 9 and 10) we get the message

    “To help protect your security, your web browser has restricted this file from showing active content that…”

    I can select the message and press “Allow blocked content…” and the app starts to work fine for the session that I have Word opened.  When I open it again I have the same issues.

    I have researched this issue and attempted to make all kinds of changes in ie and word to attempt to remove this message.

    1.  I added our servers to the list of trusted servers in ie.

    2.  I have enabled all scripting.

    3.  We are not using active X so I have not had to play with that at all.

    4.  I have reduced security in all the zones etc.

    5.  I attempted to make changes in Word Trust Center to get this to stop and I could not.

    The message finally went away when I configured our system to point to these start up files on one of our servers.  This solution makes that message go away but it causes other issues.

    So my question here is what am I missing?  Are there any other settings I should be looking for to get past this?

    Do you think this is a Word config issue or an ie issue?

    Any light you can shine on this would be greatly apprecicated.

    Thank you.

    Wayne

     

    Friday, May 24, 2013 3:16 PM

All replies

  • Hi Wayne,

    Thank you for posting in the MSDN Forum.

    I'm trying to involve some senior engineers into this issue and it will take some time. Your patience will be greatly appreciated.

    Sorry for any inconvenience and have a nice day!

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, May 27, 2013 1:34 PM
    Moderator
  • hello, I am going to enter an MSDN ticket on this also I think.  I was not sure how to do that process.
    Tuesday, May 28, 2013 2:14 PM
  • Hi Wayne,

    You can see the detailed information from http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Hope it helps.

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, May 29, 2013 3:22 AM
    Moderator
  • I have entered this as an MSDN item but I have not heard anything.
    Friday, May 31, 2013 2:04 PM
  • Hello Wayne,

    We are experience exactly the same problem with our addin.

    Any solution?

    Thanks

    Dror

    Tuesday, June 4, 2013 1:31 PM
  • Hi Wayne,

    What did you write the add-in with? VSTO, other? Is it signed with a 3rd party certificate?


    Kind Regards, Rich ... http://greatcirclelearning.com

    Tuesday, June 4, 2013 1:44 PM
  • I'm experiencing the same issue.

    This is an app created entirely using the text editor and placed in a Shared Folder network location that's been trusted in the Trust Center.

    Apps not linking to *.js files appear with no problems.

    Choosing to allow the active content does not allow the script to run.

    What's the problem and how to fix it?

    Additional information: the page displays the same warning in Internet Explorer, but unblocking does allow the code to execute, unlike in the task pane in Word.


    Cindy Meister, VSTO/Word MVP, my blog


    Wednesday, September 11, 2013 3:32 PM
    Moderator
  • I found the answer for my issue. This is specific to files stored locally: In the Advanced tab of Internet Options it's necessary to activate the checkbox "Allow active content to run from files on my computer."

    Cindy Meister, VSTO/Word MVP, my blog

    Thursday, September 12, 2013 7:51 AM
    Moderator