none
How to Remove Circular Link in a project

    Question

  • Hi,

    I have a plan of 1500 lines, wherein seems some circular links are formed and I m getting Circular linkage errors; but no where it is highlighted that which tasks are linked circularly. I m in fix I don't know how to resolve as every time I open the file it says due to Circular linking Calculations can't be performed. Is there a way to figure our which tasks are linked wrongly?

    Friday, April 13, 2012 11:17 AM

Answers

  • The most identifiable cause of circular relationships is links on summary lines. Turn off automatic calculation for a while from File - Options - Schedule -Calculation Tab, and then go to View - > Outline -> All sub tasks to expand the file. Now delete all summary links from predecessors n successors to elimniate any cause.

    Yet another quick way is create a Custom field and copy all Predecessors into it and delete all values from Predecessor Column; now copy values from this custom field and paste as it is in Predecessor column now it should prompt on pasting which all links are errorneous and leading to Circular dependencies, you can delete them.


    Sapna S

    Friday, April 13, 2012 11:28 AM
    Moderator

All replies

  • The most identifiable cause of circular relationships is links on summary lines. Turn off automatic calculation for a while from File - Options - Schedule -Calculation Tab, and then go to View - > Outline -> All sub tasks to expand the file. Now delete all summary links from predecessors n successors to elimniate any cause.

    Yet another quick way is create a Custom field and copy all Predecessors into it and delete all values from Predecessor Column; now copy values from this custom field and paste as it is in Predecessor column now it should prompt on pasting which all links are errorneous and leading to Circular dependencies, you can delete them.


    Sapna S

    Friday, April 13, 2012 11:28 AM
    Moderator
  • Ok, the first method itself worked; but would try second one if I get the issue again. Thanks.
    Friday, April 13, 2012 12:09 PM