none
Downgrade Outlook addin 2010 to 2007 RRS feed

  • Question

  • I made the addin using vs2010 and the project is an outlook 2010 addin.. i want to know if it's possible to downgrade the entire project into an outlook 2007 add-in and how.

     

    Thanks

    Thursday, August 11, 2011 8:51 PM

Answers

  • If you are using Framework 4 full or client profile you can embed the Outlook and Office PIA's and if your code only uses methods/properties/events exposed in the 2007 object model the code will execute without problems. If you call a property or method that's only 2010 you'd need to check for runtime version first or you'd crash Outlook.
     
    If you aren't embedding the PIA's and using Framework 4 then you'd need to develop and compile the addin on a machine with Office 2007 installed (no 2010) and build your application there. The rule of thumb is to develop on a machine with the oldest version of Outlook you want to support installed on the dev machine.

    --
    Ken Slovak
    MVP - Outlook
    http://www.slovaktech.com
    Author: Professional Programming Outlook 2007
     
     
    "ankie320" <=?utf-8?B?YW5raWUzMjA=?=> wrote in message news:4b23d02b-73e2-403e-aecd-893d2b19628a...

    I made the addin using vs2010 and the project is an outlook 2010 addin.. i want to know if it's possible to downgrade the entire project into an outlook 2007 add-in and how.

     

    Thanks


    Ken Slovak MVP - Outlook
    Friday, August 12, 2011 1:31 PM
    Moderator