none
Still!!! server side activities have been updated. restart SPD to use the updated version of activities

    Question

  • server side activities updated... restart SPD to use latest activities"

    pretty huh? I have been working with SP13 online and a custom list which I would simply like to add a workflow too,

    When creating a workflow I receive this error, I have uninstalled SPD I have cleared/deleted cache files in the following locations:

    <user profile>\appdata\roaming\microsoft\SharePoint Designer\ProxyAssemblyCache
    < user profile>\appdata\local\microsoft\websitecache\<sitename>

    restarted computer

    reinstalled SPD

    and...same message "server side activities updated... restart SPD to use latest activities"

    Same Image as above

    Now what else can I do, there aren't any language packages other than the default English, and a lot of people find this issue with no luck as to a resolution, need an answer that will work

    Wednesday, June 04, 2014 1:22 PM

Answers

  • Hi Zenas,

    Please try installing Designer in another machine and try.

    Also try out the below threads.

    http://sharepoint.stackexchange.com/questions/94208/error-while-saving-list-workflow-in-sharepoint-designer-2013

    http://social.technet.microsoft.com/Forums/sharepoint/en-US/5796972e-3a92-4306-8cf1-e1e7b9ab9635/error-while-saving-a-workflow-via-sharepoint-designer-serverside-activities-have-been-updated-you?forum=sharepointcustomization


    Please remember to click 'Mark as Answer' on the answer if it helps you

    Wednesday, June 04, 2014 1:31 PM

All replies

  • Hi Zenas,

    Please try installing Designer in another machine and try.

    Also try out the below threads.

    http://sharepoint.stackexchange.com/questions/94208/error-while-saving-list-workflow-in-sharepoint-designer-2013

    http://social.technet.microsoft.com/Forums/sharepoint/en-US/5796972e-3a92-4306-8cf1-e1e7b9ab9635/error-while-saving-a-workflow-via-sharepoint-designer-serverside-activities-have-been-updated-you?forum=sharepointcustomization


    Please remember to click 'Mark as Answer' on the answer if it helps you

    Wednesday, June 04, 2014 1:31 PM
  • Hi Wendy,

    I have the same problem and have followed the same steps with exactly the same result.  While this works from another machine, I want SPD 2013 to work on THIS machine with Office 365.  I'm a partner too, and there's no acceptable reason that there is no clear resolution to this problem other than using some other machine.

    Friday, July 18, 2014 6:03 AM
  • Hey Eric,

    How were you able to get it to work on the other machine?  I have been struggling with this issue for days.  WHat are the settings that are different? 

    Microsoft does not know the cause of the error.  It seems some people have this working while others do not.  There is no rhyme or reason.

    Saturday, July 19, 2014 4:33 AM
  • I'm having the same problem also, any one having any luck figuring out the cause?

    Dean MCTS-SQL 2005 Business Intelligence, MCITP SharePoint 2010

    Thursday, August 14, 2014 7:48 PM
  • In my case the solution to this problem was the following. I discovered that the contents of <user profile>\AppData\Local\Microsoft\WebsiteCache\<sitename>\<version> was empty aside from Activity.xml for the website in question. This directory should actually download the following list of files from the server in order for the workflows to operate in SPD. This is not the case when things go wonky.

    Microsoft.ReportingServices.SharePoint.UI.WebParts.Proxy.dll
    Microsoft.SharePoint.WorkflowServices.Activities.Proxy.dll
    Microsoft.Web.Design.Client.dll
    Newtonsoft.Json.dll
    ProxyAssembly.xml
    System.Net.Http.dll
    System.Net.Http.Formatting.dll
    System.Net.Http.Formatting.xml
    System.Net.Http.xml
    System.Web.Entity.Proxy.dll
    System.Web.Extensions.Proxy.dll

    So I found that if I copied these from another websitecache directory that is working or perhaps copying them from another machine where SPD is working properly that my workflows will start working once again. I haven't checked but I'm certain that you could hunt down all these dll's manually on the server as well.



    • Edited by Chandler C Tuesday, December 23, 2014 7:35 PM
    Tuesday, December 23, 2014 7:31 PM
  • Hi guys.

    My solution:

    1. Turn off Distributed cache service on all servers in the farm in the "Manage services in the farm".

    2. Make iisreset on each server

    3. Start just on the one server Distributed cache

    4. Clear sharepoint designer 2013 cache as above in this topic

    5. start designer and open workflow for editing.

    Thursday, November 12, 2015 11:13 AM
  • I can not do IIS reset as this is office 365 and I have the same issue

    MCTS Sharepoint 2010, MCAD dotnet, MCPDEA, SharePoint Lead


    Monday, November 16, 2015 8:03 PM
  • Ah!

    It worked from another machine!!


    MCTS Sharepoint 2010, MCAD dotnet, MCPDEA, SharePoint Lead

    Monday, November 16, 2015 8:06 PM
  • yo! After copying working cache and website cache files from working designer box to non working box designer cache it started working there too!!

    MCTS Sharepoint 2010, MCAD dotnet, MCPDEA, SharePoint Lead


    Monday, November 16, 2015 8:32 PM
  • I tried many of the same steps with no luck on Windows 10 with Office 2016:

    •  Reinstalling SPD 2013 in 32 and 64 bit versions
    • Applying Service Pack 1 and the August 2015 Updates
    • Clearing out the caches
    • Remove Workflow Manager Client (I have Workflow Manager Tools installed with Visual Studio 2015 but see no way to remove them)

    After running Process Monitor while trying to save a workflow, I was able to confirm the same suspicions mentioned previously:

     The Microsoft.SharePoint.WorkflowServices.Activities.Proxy.dll file was missing from the C:\Users\USER_NAME\AppData\Local\Microsoft\WebsiteCache\SITE_NAME\ directory.

    Copying another version from a different computer to the cache directory fixed the problem for this site.  Unfortunately, it must be copied for every site.

    Monday, November 16, 2015 10:18 PM