locked
NET 4.5 "not installed" error during Sharepoint install RRS feed

  • Question

  • Hello,

    We successfully ran prerequisiteinstaller.exe,  installed sql 2014,  started the SharePoint 2013 setup.exe program, but get this error: "setup is unable to proceed for the following error(s)"  This product requires Microsoft .NET 4.5". .NET 4.5 is already installed on the server. Any ideas appreciated .

    Box environment: Win Server 2012 R2, sql 2014, SharePoint 2013 Ent (w/ SP1)

    TIA,

    edm2

    Thursday, July 14, 2016 9:48 PM

Answers

  • Here is the resolution for you

    https://support.microsoft.com/en-us/kb/3087184


    Please remember to click 'Mark as Answer' on the answer if it helps you

    • Proposed as answer by Trevor SewardMVP Thursday, July 14, 2016 10:26 PM
    • Marked as answer by edm2 Friday, July 15, 2016 5:58 PM
    Thursday, July 14, 2016 9:51 PM

All replies

  • Here is the resolution for you

    https://support.microsoft.com/en-us/kb/3087184


    Please remember to click 'Mark as Answer' on the answer if it helps you

    • Proposed as answer by Trevor SewardMVP Thursday, July 14, 2016 10:26 PM
    • Marked as answer by edm2 Friday, July 15, 2016 5:58 PM
    Thursday, July 14, 2016 9:51 PM
  • That's very interesting. I just realized that Sql SSMS 2016 was installed not sql 2014 SSMS on the SharePoint box! I wonder if that updated SSMS version pulled in NET 4.6 and screwed things up

    edm2

    P.S. Makes me hesitant to install SSMS 2016 on the SharePoint box even after SharePoint is successfully installed.

    Just saw this at the bottom of the link you provided:>>>> After SharePoint is installed successfully, you can upgrade from the .NET Framework 4.5.2 to the .NET Framework 4.6 or 4.6.1.

    • Edited by edm2 Thursday, July 14, 2016 10:39 PM
    Thursday, July 14, 2016 10:37 PM