none
Sharepoint search stopped working RRS feed

  • Question

  • We have a Sharepoint 2010 server that the search functionality had stopped working either after we made a change to force users to access the HTTPS site or after a Windows update two weeks ago.  When I look at the crawl, it fails with a "The secure sockets layer (SSL) certificate sent by the server was invalid and this item will not be crawled" and I am unable to get past this.  We're using a wildcard cert and I have verified that the certificate is valid.  

    I have tried so many things that I may miss some that I have tried listed...

    • Making sure the "Ignore SSL warnings..." is checked
    • Verified the registry entries are listed
    • Rebooted the Sharepoint server and the SQL server
    • Verified farm account had access to the databases
    • Several more items that I'm drawing a blank on

    Is there something else that I'm missing?  What other info could I provide to assist in helping me on this issue?

    Thank you in advance for taking the time to assist me on this.

    Monday, May 14, 2018 3:34 PM

All replies

  • Hi Fanning,

    Based on your description, my understanding is that  search function had stopped working in SharePoint 2010.

    You can try cleaning the configuration cache and doing an IISREST, then check if the issue is resolved.

    Information about Clearing SharePoint configuration cache, you could refer to the following article.

    https://blogs.msdn.microsoft.com/jamesway/2011/05/23/sharepoint-2010-clearing-the-configuration-cache/

    Best regards,
    Ethan Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, May 15, 2018 7:47 AM
  • Ethan:

    Thank you for the reply, I have tried that suggestion and it still is giving us the SSL error, unfortunately.  

    Eric

    Tuesday, May 15, 2018 2:25 PM
  • We have a Sharepoint 2010 server that the search functionality had stopped working either after we made a change to force users to access the HTTPS site or after a Windows update two weeks ago.  When I look at the crawl, it fails with a "The secure sockets layer (SSL) certificate sent by the server was invalid and this item will not be crawled" and I am unable to get past this.  We're using a wildcard cert and I have verified that the certificate is valid.  

    I have tried so many things that I may miss some that I have tried listed...

    • Making sure the "Ignore SSL warnings..." is checked
    • Verified the registry entries are listed
    • Rebooted the Sharepoint server and the SQL server
    • Verified farm account had access to the databases
    • Several more items that I'm drawing a blank on

    Is there something else that I'm missing?  What other info could I provide to assist in helping me on this issue?

    Thank you in advance for taking the time to assist me on this.

    Hi Mr. Fanning,

    Not sure if you resolved this issue yet.  Please make sure that the account that search services in windows services.msc is using is different than the account being used to crawl.  the account being used to crawl can me seen in the search service application.

    Open a browser using this account shown in the search service application, then try and browse to one of the https url's, see if you get a certificate error on the server.  Also, very important, make sure server has a hosts entry so that it crawls itself locally.  And, make sure the Microsoft SharePoint Foundation Web application service instance is online on this server.

    Are you able to browse the site using the crawl account?  Is the crawl account listed in the User Policy of the web application with read on all zones?


    Stacy Simpkins | MCSE Productivity | MCSE SharePoint 2013 | anothersharepointblog.com

    Tuesday, July 24, 2018 2:25 PM