none
User titles containing "&" are double after upgrade to March CU RRS feed

  • Question

  • After upgrading to March CU we notice that users who have some title contain "&" is displaying there title twice. Eg.

    Jan Knudsen

    IT & Sharepoint Consultant

    =

    Jan Knudsen

    IT & Sharepoint Consultant IT & Sharepoint Consultant

    Any of you experiences the same thing and did you find a fix for it?

    Friday, August 9, 2013 12:37 PM

Answers

  • Hi Jan,

    thank you for your hardwork,

    i am not quite sure if you create new search service application with new database, will it comes correctly as this is the last steps that i had in mind now, so create a dummy search and if by using the dummy search makes it right, then we may remove the old search service application.

    if the last steps still not work and it seems we dont have much options left, we need to check your search database, to do this we cant help by this support type.

    you may have to open a ticket regarding this issue, then we will try to remote your environment and check it out for you.

    if you have a development stage, perhaps you may try to update it to the next cumulative update http://technet.microsoft.com/en-us/sharepoint/jj891062.aspx


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Jan Knudsen Monday, September 2, 2013 7:11 AM
    Friday, August 30, 2013 6:47 AM
  • Hi Aries,

    Success! After installing the August CU and do a reset of the index/Full crawl, my titles are finally shown correct.

    Thank you for your time. Really appreciate it.

    Update:Just tested it with March CU again and ran psconfig once again and a reset index/full crawl. It works aswell so it was the psconfig that ran again that fixed the issue.

    • Marked as answer by Jan Knudsen Monday, September 2, 2013 7:12 AM
    • Edited by Jan Knudsen Monday, September 2, 2013 8:10 AM
    Monday, September 2, 2013 7:11 AM

All replies

  • Hi,
    For this issue, I’m trying to involve someone familiar with this topic to further look at it.
    Thanks,

    Qiao Wei
    TechNet Community Support

    Wednesday, August 14, 2013 9:00 AM
    Moderator
  • Thank you,

    I havent been able to figure it out other than its consistent on my dev, test and production environment after updating to March CU. Before that it was working fine.

    Let me know if you need more information.

    Wednesday, August 14, 2013 9:04 AM
  • Hi Jan,

    it is my first time that i recall to have your issue, but i had similar this issue as in the article:http://consultingblogs.emc.com/mattlally/archive/2012/01/06/sharepoint-2010-validate-special-characters.aspx

    perhaps its not the same with your issue.

    if possible can you help us by print screen the issue, so we aware, and i will try to do some research regarding the issue?

    most probably the simpliest workaround, is to ask user to update the information.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, August 14, 2013 9:28 AM
  • Hi Aries,

    Here's a screenshot.

    Its only when doing people search.

    thank you

    Friday, August 16, 2013 1:18 PM
  • Hi Jan,

    i tried to create some users with special characters, by using sharepoint 2010 with March update 2013.

    as we tried on our lab, seems the issue is not re-produceable at our lab box.

    the title that user account have in sharepoint, is pulled from the AD when there is a process of sync, and the data should be go to the mysite section, as there is a section for user details and properties.

    please help to check the AD, if should the data is correct from there, is from AD is correct, then perhaps we need to update the user account from sharepoint

    you may go to your central admin and go to user profile application on manage service application.

    open to manage user profile, then search for the user that having the issue, and edit the user properties.

    this issue happenend most probably, sharepoint is using the special characters for item separator list.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, August 21, 2013 2:50 AM
  • Hi Aries,

    I have verified that the titles are correct in AD. The above example: "Project Coordinator & Graphic Designer" is only located once.

    I've I change the title to "and" instead of "&" in UPS and run a crawl it displays correctly. If I change it back to "&" it again displays twice.

    Even tried to change the search results page to use the default display template however the results remain the same.

    Again, it worked before March CU so the whole setup should be correct?

    Wednesday, August 21, 2013 7:51 AM
  • Hi Jan,

    in general, for people search, just get index from user profile.

    if should there is no issues regarding with user profile, then perhaps may have issues with the search webpart or the crawling data, then the result appear not right.

    for example,

    if i see mysite for the issued user, then the duplicate after '&' will not be there,

    but when we search people then appear the result as duplicate, then the webpart of search or the crawling data got issue,

    i am using sharepoint 2010 with march update, and create people search box webpart and try to search it appear ok, the issue is not re-producable at our lab box.

    if you have the time, please try to create another blank page, consist 2 webparts, people search webpart and search result core, set the people search result to the same page,

    it may appear and my labbox appear like:

    if you should have a development stage, perhaps you may also update it to april 2013 cu for trial.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, August 21, 2013 9:08 AM
  • Hi Aries,

    I see now that I havde made a mistake. Very sorry about this but I'm running Sharepoint 2013 March CU not Sharepoint 2010. This was accidently posted in the wrong forum :-( Hopefully you are able to produce the error now?

    The search results are displaying the title twice but mouse over and in UPS and everywhere else it is displayed only once.

    Wednesday, August 21, 2013 9:14 AM
  • Hi Jan,

    please provide me some time to build the sharepoint 2013 for testing.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, August 21, 2013 9:40 AM
  • Hi Jan,

    Thank you for waiting,

    i did some research to couple of environment since i couldnt reproduce it at first environment.

    from 3 times trying, at last i was able to reproduce your issue.

    i attached the pictures, hopefully the situation is similar:

    after did some research locally, i managed to make it gone,


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, August 29, 2013 8:53 AM
  • Hi Aries,

    Thanks for your time

    This is the exact problem I have. How did you fix it then?

    Thursday, August 29, 2013 8:57 AM
  • Hi Jan,

    the reason why the data is not correct in my environment, it is because of a glitch that i made, i full sync user profile and crawl together, then the data may not be correct.

    as i checked the data stored, seems all the data about user profile is correct, but at crawl database had glitchs, so need to re-index and re-do the full crawl

    these are the steps that i did,

    1. check and re-check crawl rules,

    2. restart the index at crawl settings,

    3. full crawl everything,

    perhaps you may try this steps and revert us the updates.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, August 29, 2013 8:59 AM
  • Hi Aries,

    Tried the above however I'm afraid the results are still the same in my end.

    Was the titles without a "&" sign displayed once in your environment aswell?

    Thursday, August 29, 2013 9:37 AM
  • Hi Jan,

    at my environment is ok, with or without '&' it shows correctly.

    lets have a try for testing, perhaps it can help to trigger something,

    1. find a user that dont have '&', for example administrator user.

    2. add the title with '&' at the User AD, so basically from AD, it already contain the '&' char.

    3. try to do search, should be the title not come out yet, so we do user sync,

    4. after sync, we do index reset, full crawl.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, August 29, 2013 9:44 AM
  • Hi Aries,

    Ran out of time today I'll test this tomorrow and get back.

    Thank you

    Thursday, August 29, 2013 9:57 AM
  • Hi Aries,

    Tried to update the title in AD and put in "&" in my own title and do an import, reset index and do a full crawl. Same results: my title is double. The results are the same when I change the title in AD or when I change the title directly in UPS.

    This is so strange since everything regarding the titles was shown correctly on both my environments before updating to March update.

    Friday, August 30, 2013 6:32 AM
  • Hi Jan,

    thank you for your hardwork,

    i am not quite sure if you create new search service application with new database, will it comes correctly as this is the last steps that i had in mind now, so create a dummy search and if by using the dummy search makes it right, then we may remove the old search service application.

    if the last steps still not work and it seems we dont have much options left, we need to check your search database, to do this we cant help by this support type.

    you may have to open a ticket regarding this issue, then we will try to remote your environment and check it out for you.

    if you have a development stage, perhaps you may try to update it to the next cumulative update http://technet.microsoft.com/en-us/sharepoint/jj891062.aspx


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Jan Knudsen Monday, September 2, 2013 7:11 AM
    Friday, August 30, 2013 6:47 AM
  • Hi again,

    glad to see there are still options available :-)

    I tried to created a new search service application with new databases and associate it to the default application proxy and remove / delete the old one. added content sources and did a full crawl. Same results.

    I also tried to create a new webapplication with a standard publishing sitecollection and new search center. Same result.

    Only thing left is the newest CU. I'm download that now and will give feedback back once I've tested it.

    Thank you

    Friday, August 30, 2013 8:22 AM
  • Hi Aries,

    Success! After installing the August CU and do a reset of the index/Full crawl, my titles are finally shown correct.

    Thank you for your time. Really appreciate it.

    Update:Just tested it with March CU again and ran psconfig once again and a reset index/full crawl. It works aswell so it was the psconfig that ran again that fixed the issue.

    • Marked as answer by Jan Knudsen Monday, September 2, 2013 7:12 AM
    • Edited by Jan Knudsen Monday, September 2, 2013 8:10 AM
    Monday, September 2, 2013 7:11 AM
  • Are you doing this in SharePoint 2013? I am currently running SharePoint 2013, build number 15.0.4535.1000, which is August CU, I ran the Configuration utility again, Reset the index, and then did a full crawl and I am still seeing double Job Titles in the people search.
    Tuesday, December 17, 2013 9:54 PM
  • Hi bshamster1,

    Both the Search content webpart and the search results page show the title correct on my development environment now:

    I'm still running the March CU (Build 15.0.4481.1005) on my environment though since it worked after running psconfig again and reset the index/full crawl. But like tested before its also working with August CU - atleast from my environment.

    Wednesday, December 18, 2013 10:02 AM
  • Actually I ran into this again today and noted another possible solution.

    In search scema I selected the managed property "jobtitle". Under "mappings to crawled properties" select "include content from the first crawled property that is not empty". By default it includes all properties and since sps-jobtitle and title is both pulled from AD the title is double.

    Tuesday, May 6, 2014 8:53 AM
  • I found that Jan Knudsen's solution worked perfectly for a quick fix.  Will look to apply the updates for a long term fix but needed a quick resolution (CEO's title was duplicating).
    Monday, May 12, 2014 3:03 PM
  • Hej Jan

    Thanks, it worked perfectly as well for me..

    Best

    Regards

    Trine Andersen

    Thursday, October 29, 2015 9:01 AM
  • Hej Trine, Glad to see this helps others :-) /Jan
    Thursday, October 29, 2015 6:12 PM
  • Thanks Jan, has this issue and your changes in search schema fixed the issue.
    Tuesday, April 9, 2019 7:23 PM