none
What did I do wrong here? One particular If-Then command does not work in my workflow RRS feed

  • Question

  • Hi all,

    I have a three-step approval workflow. Below it shows part of the process in the second step. All the If-Else commands work well except for the last one where I want the workflow to pause for a bit then send the reminder email. (I put 5 mins here just to test it). However, this one does not work, essentially I want to set up reminder emails.

    Any insights?

    Many thanks,

    Aaron 

    Friday, October 21, 2016 10:33 AM

Answers

  • Hi aa_hhu,

    If I understand correctly the last email action is not happening after you pause workflows for 5mins?

    Can you please add Log to History action after the If condition and check if it is successfully going there because i don't see any issue in your workflow and it should just for 5mins before sending an email.


    SharePoint School | Blog- http://www.sharepoint-journey.com

    • Marked as answer by aa_hhu Tuesday, October 25, 2016 11:54 AM
    Saturday, October 22, 2016 7:43 AM
  • Hi aa_hhu,

    Like Devendra, please add a "log to History List" action into the last IF section to check if the IF command is executed.

    In addition, please check the workflow history, check if there is a comment about "Pause for..." for the Pause action and also there is something about the email sending.

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Monday, October 24, 2016 8:40 AM
    Moderator

All replies

  • Hi aa_hhu,

    If I understand correctly the last email action is not happening after you pause workflows for 5mins?

    Can you please add Log to History action after the If condition and check if it is successfully going there because i don't see any issue in your workflow and it should just for 5mins before sending an email.


    SharePoint School | Blog- http://www.sharepoint-journey.com

    • Marked as answer by aa_hhu Tuesday, October 25, 2016 11:54 AM
    Saturday, October 22, 2016 7:43 AM
  • Hi aa_hhu,

    Like Devendra, please add a "log to History List" action into the last IF section to check if the IF command is executed.

    In addition, please check the workflow history, check if there is a comment about "Pause for..." for the Pause action and also there is something about the email sending.

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Monday, October 24, 2016 8:40 AM
    Moderator