none
Newly promoted column in infopath not displaying value in sharepoint 2007 form library RRS feed

  • Question

  • Hi All,

    I have a form library, which is allready having nearly 200 forms. Now i need to promote some more infopath 2007 form fields to sharepoint 2007 list column. But after promoting and re-publishing the infopath template, newly promoted columns does not show any value. Please suggest me how to fix this problem?

    Work around :- If i just open a form and save it back, newly promoted field(Sharepoint library column) is displaying correct value. But this would be a tedious task if it has to be done for nearly 200 forms.

     


    Thanks - Rajkumar Rurhi
    Monday, May 9, 2011 12:13 PM

Answers

  • Actions > Open in Windows Explorer

    Watch the icons slowly appear, and when they all appear, click Page Down, and wait again.  Do this until you get to the bottom, then close the window and re-open the form library.  For any stragglers, just open them individually and re-submit.

    Be careful if you ever use Re-link, because that will trigger any workflows set to run on Edit.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by Leoyi Sun Friday, May 13, 2011 10:16 AM
    Tuesday, May 10, 2011 2:37 AM

All replies

  • You could use the Relink Documents view of your form library.  You have to check the box next to each form that you want to relink to the new form template - unfortunately there isn't a "check all" feature, so you have to do a lot of click-click-click... but that's better then opening each one and saving.
    Monday, May 9, 2011 8:27 PM
  • Actions > Open in Windows Explorer

    Watch the icons slowly appear, and when they all appear, click Page Down, and wait again.  Do this until you get to the bottom, then close the window and re-open the form library.  For any stragglers, just open them individually and re-submit.

    Be careful if you ever use Re-link, because that will trigger any workflows set to run on Edit.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by Leoyi Sun Friday, May 13, 2011 10:16 AM
    Tuesday, May 10, 2011 2:37 AM
  • Thanks Cobb,

    Its working.


    Thanks - Rajkumar Rurhi
    Monday, May 16, 2011 10:07 AM
  • Wow I don't know why this works but you just saved me hours of opening and saving 400 forms. THANKS Clayton.
    Tuesday, August 30, 2011 3:17 PM
  • Utter madness but it does the job!

    Thanks a million Clayton, you saved me opening over 1600 forms (Not that it's contest or anything Tmstuder :) )

    Monday, May 14, 2012 7:39 PM
  • Hi Cobb,

    Really Cool... It helped me to save few hours to reopen and save around 70 documents.... :).... Thanks a Lot..

    Monday, November 5, 2012 9:46 AM
  • Hi, this post is very confusing almost like all the information is hidden, I have same issue that if I add new promoted fields they are not added to the library automatically and all works seamlessly, have not found a solution as of yet on the internet, I feel that the issue goes a lot deeper than we know, if anyone do have a solution (this is now without trying to edit the manifest.xsf file, which I consider to be impossible, it is completely unreadable to me)

    Jos

    Wednesday, November 7, 2012 9:25 AM
  • Cool...got the solution, it seems that things go out of synch if you do not do it in the absolute correct order, think that the housekeeping is not done correctly if you do not follow the exact procedure :

    1. Deactivate the Form on the Form Services

    2. Remove the form from the Form services

    3. Delete the content types from the library and from the root site collection

    4. Republish your project (browser based!) to a folder

    5. re-upload the form and then re-activate

    6. Add the contenbt type back to the library

    Success!

    Not sure what will happen to the existing forms in the library, plus you probably will not be able to delete the content types if they are still linked, so you probably need to relink them to another content type first, will come back to this post on this issue, as soon as I have a change request on it on live.

    • Proposed as answer by Jos Wilson 911 Wednesday, November 7, 2012 10:05 AM
    Wednesday, November 7, 2012 9:54 AM
  • Hi Jos -

    Actually all you need to do is deactivate the form from the very top level of the site & reactivate.  You shouldn't need to remove the form or delete content types from libraries (which would not work if there are forms already saved in that library using that content type - it would not even allow you to remove the content type).

    I hope that helps!

    Melissa

    Wednesday, November 7, 2012 1:46 PM
  • Thanks Melissa,

    Will test this as soon as possible, it is interesting though that it removes it without deactivating it.....why is this?

    Jos

    Thursday, November 8, 2012 9:10 AM
  • Wow! What a genious! Thanks man!
    Thursday, November 8, 2012 12:17 PM
  • Jos,

    I wish I knew....  :)

    Melissa

    Thursday, November 8, 2012 1:49 PM
  • I tried this, thinking there was no possible way it could be that simple.

    I was wrong, it is that simple. Thanks, Clayton!

    Wednesday, July 31, 2013 9:11 PM
  • Hi I am facing a similar problem, I have an infopath form  browser enabled and when I fill the data and hit the submit button three fields values are not saved in the form library list, two fields are time date type and the other one is a repeating table, any idea why this field values are not making it to the corresponding sharepoint columns? 

    Thank you very much.

    Wednesday, October 2, 2013 9:55 PM
  • Hi,

    This solution had worked for me in the past but one day I needed to utilise this solution only to find that nothing was happening when I opened my Document Library in Explorer...

    After trying my best to avoid having to open and close each and every form in my library, I found that the Default Program associated with the XML file type was causing a problem (Despite the fact that the Default Program was InfoPath). Initially, I tried changing the associated program to something else (e.g. Notepad) and then back to InfoPath but it didn't help.

    Changing the Default Program to XML Editor (C:\Program Files (x86)\Common Files\microsoft shared\OFFICE14\msoxmled.exe) fixed the problem for me. After I did that the XML icons systematically began displaying in Explorer and the promoted columns were refreshed.

    Note: Your InfoPath forms will still open in InfoPath. MSOXMLED simply acts as a router for MS Office XML files so that an Excel XML file will open in Excel, an InfoPath XML file will open in InfoPath, etc.

    All the best,

    Ben

    Friday, February 28, 2014 3:34 PM
  • Hi Melissa 

    I quite unable to understand this 

    currently we have similar issue 

    What you mean by deactivate from top level site ?

    It would be a great help if you could respond me back 

    Thanks for your support

    Monday, December 17, 2018 9:16 PM