none
The query cannot be run for the following DataObject: InfoPath cannot run the specified query. Access is denied

    Question

  • Hi,

    when i create a new infopath form, add data connection of sharepoint list to retrieve data from sharepoint and try to preview form, i get the following error:

    "The query cannot be run for the following DataObject: InfoPath cannot run the specified query. Access is denied."

    please help.

    Tuesday, November 06, 2012 5:42 AM

All replies

  • Hi,

    Make sure that you have at least read right on list so you can get the data from list. Please check you permission in list and let us know your result


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Tuesday, November 06, 2012 11:50 AM
    Moderator
  • Hi Hemendra,

    I have 'Full control' set on the list. please advise.

    Wednesday, November 07, 2012 9:50 AM
  • Hi,

    Now check the form security so in InfoPath form - > tools menu-->form options -> security and trust from the left panel -> uncheck automatically determine security level --> select full trust radio button and click ok

    Let us know your result


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Thursday, November 08, 2012 5:23 AM
    Moderator
  • Hi Hemendra,

    There is no 'Tools' menu in infopath task form.

    Now the thing is that I can see all the data of the list. i want to filter it to see data specific to the item only. I have created a rule where i created a condition as 'ID='23' But still it displays all the result. could you please help.

    Thursday, November 08, 2012 6:54 AM
  • Hi,

    Now this is different issue, so need to check your condition when filling the data so can you please post any screen or some clue about your data.


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Thursday, November 08, 2012 7:15 AM
    Moderator
  • Hi Hememdra,

    i try to display only the specific data on condition of ID != task list 'related content' id as below.

    if ID!= related content id  then hide the row. i tried with hardcode data and it works fine. but when i use the condition as below it doesnt display any result. please advise.

    Thursday, November 08, 2012 9:14 AM