none
SharePoint designer cannot display the item - workflows RRS feed

  • Question

  • Hi,

    I have a few custom SharePoint designer workflows. The workflows have been working properly. I wanted to do some modifications to existing workflow.

    SharePoint version: 4 (15.0.0.4551) (Got this from home page of the site in SPD)

    I opened the site in designer, selected workflows option- selected the workflow whcih i wanted to modify. I am getting error as:

    sharepoint designer cannot display the item
              what you can try
             
              click the refresh button or press F5 to refresh the content of your site

              Go back to the previous page

               Most likely issues

              The file has been deleted from te site

              The site is encountering problems

    I have verified this:

    http://social.msdn.microsoft.com/Forums/sharepoint/en-US/b05a8bba-5bef-4981-be4f-d63e8f7933d9/sharepoint-designer-cannot-display-the-item?forum=sharepointcustomizationprevious

    but has not helped.

    How to fix this?

    Thanks

    Thursday, April 10, 2014 3:32 PM

Answers

  • Hi,

    I created a 2010 site on my SharePoint Server 2013, I could open it with my SharePoint Designer 2013, and it worked for workflow. The SharePoint version is 4 (15.0.0.4420) from Designer.

    In addition, as the version is 4 (15.0.0.4551), did you created the site as I in SharePoint server 2013 or migrated it to 2013?

    Regards,


    Rebecca Tu
    TechNet Community Support

    Monday, April 14, 2014 1:46 AM

All replies

  • Hey Venkatzeus,

    Have you tried doing a complete un-installation of your existing SharePoint Designer? Make sure you have the folder deleted from the program files (x86) and the registry.

    Then do an a full installation again and then access your site and re-design the workflow.

    Let me know how that goes.


    Daniel Christian (MCTS)

    Friday, April 11, 2014 12:43 AM
  • Hi,

    Please confirm if you have done the following steps on your side:

    1. Uninstall SharePoint Designer 2010 if installed.
    2. Uninstall SharePoint Designer 2013.
    3. Use Windows Explorer to open these 3 locations and delete all the files there:
            C:\Users\<username>\AppData\Local\Microsoft\WebsiteCache
            C:\Users\<username>\AppData\Roaming\Microsoft\SharePoint Designer\ProxyAssemblyCache
            C:\Users\<username>\AppData\Roaming\Microsoft\Web Server Extensions\Cache
    4. Reboot the client.
    5. Install SharePoint designer 2013 with the latest updates packaged.
    6. Open SPD 2013, connect to the site and edit the workflow.

    Regards,

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com .


    Rebecca Tu
    TechNet Community Support

    Friday, April 11, 2014 6:34 AM
  • Hi,

    Please confirm if you have done the following steps on your side:

    1. Uninstall SharePoint Designer 2010 if installed.
    2. Uninstall SharePoint Designer 2013.
    3. Use Windows Explorer to open these 3 locations and delete all the files there:
            C:\Users\<username>\AppData\Local\Microsoft\WebsiteCache
            C:\Users\<username>\AppData\Roaming\Microsoft\SharePoint Designer\ProxyAssemblyCache
            C:\Users\<username>\AppData\Roaming\Microsoft\Web Server Extensions\Cache
    4. Reboot the client.
    5. Install SharePoint designer 2013 with the latest updates packaged.
    6. Open SPD 2013, connect to the site and edit the workflow.

    Regards,

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com .


    Rebecca Tu
    TechNet Community Support

    Hi,

    The site I have is in SharePoint 2010. 

    Will installing SharePoint designer 2013 open the SharePoint 2010 site?

    Thanks

    Friday, April 11, 2014 11:26 AM
  • Hi,

    I created a 2010 site on my SharePoint Server 2013, I could open it with my SharePoint Designer 2013, and it worked for workflow. The SharePoint version is 4 (15.0.0.4420) from Designer.

    In addition, as the version is 4 (15.0.0.4551), did you created the site as I in SharePoint server 2013 or migrated it to 2013?

    Regards,


    Rebecca Tu
    TechNet Community Support

    Monday, April 14, 2014 1:46 AM
  • Thank you so much for perfect solution and it is working like a charm after followed your instructions.

    Saved my day :)

    Thursday, August 8, 2019 10:29 AM