none
Revert newform to default SharePoint list form RRS feed

  • Question

  • Hi,

    We have a requirement like below:

    1. We created a custom list - "Customers"

    2. We customized the form using infopath 2010.

    3. Now we opened the list using sharepoint designer 2010. There under the "All files-> lists->"customers" (our list).

    4. We found the following items - newform, editform, dispform and a folder called "Customers". When we opened the "Customers" folder, we found the following files -> displayifs, newifs, editifs and an ".xsn" infopath template file.

    5. We by mistake deleted the folder "Customers" containing the files (displayifs, newifs so on).

    6. Now when we take the list in the url and click the "new item" option, it is showing  that the page cannot be displayed. We noticed that the url is pointing to the infopath form newifs.aspx.

    7. Now please guide us , how can we point the new item option to the default sharepoint "newform.aspx". When we browsed, we found an article where they are explaining to right click on the form (newform.aspx) and click the option "Reset to site definition". This option is not available for us.

    Please advice, Thanks in advance.

    Veena R

     


    Veena Raju
    Friday, June 17, 2011 2:25 PM

Answers

  • The default form is associated with the list itself, but if you create a new form you have the option to associate the form with a content type (especially if more than one CT exist). You will find short tutorials across the web or at http://blogs.msdn.com/b/infopath/ but if you need to master it, you should get a book (I believe there are at least 2 already published) and watch some intro training like those from Lynda - this will help you get the big picture as blog posts usually focus on certain technical issues.
    AK
    • Marked as answer by Veenar Friday, June 17, 2011 4:20 PM
    Friday, June 17, 2011 4:15 PM
  • Infopath forms are associated with content types, so what you saw is true. To fix, go to list settings (from browser), form settings (under general settings) and toggle the radio buttons (select: <label for="ctl00_PlaceHolderMain_FormSettingsOptionSection_ctl00_RevertInfoPathEnabledListRadioButton">Use the default SharePoint form)</label>. You have option to delete InfoPath forms.
    AK
    • Marked as answer by Veenar Friday, June 17, 2011 3:35 PM
    Friday, June 17, 2011 3:29 PM

All replies

  • Try this: in SPD, click Lists and Libraries (not all files), select your list and open the details area (list information, views, ... forms). In the forms section, you should see a list of files (the default ones will be there and may be the ones with ifs - infopath). Highlight your newform.aspx and from the ribbon, click set as default. Same with display and edit.
    AK
    Friday, June 17, 2011 2:44 PM
  • Hi,

    We managed to get the deleted infopath displayifs.aspx file back. We opened the customize list in infopath201 again.

    But what we require is instead of infopath 2010 forms (displayifs.aspx so on) , we require newform.aspx, editform.aspx as the defualt forms.

    We navigated as you adviced, but there is not option to set as default for the forms. And in the "default" column in the forms section, the "Yes" value is set to the newform.aspx, displayform.aspx. But on click of the add item option for the list, the infopath 2010 form is displayed.

    Please advice how to revert back. Thanks in advance

    Veena R

     


    Veena Raju
    Friday, June 17, 2011 3:06 PM
  • Infopath forms are associated with content types, so what you saw is true. To fix, go to list settings (from browser), form settings (under general settings) and toggle the radio buttons (select: <label for="ctl00_PlaceHolderMain_FormSettingsOptionSection_ctl00_RevertInfoPathEnabledListRadioButton">Use the default SharePoint form)</label>. You have option to delete InfoPath forms.
    AK
    • Marked as answer by Veenar Friday, June 17, 2011 3:35 PM
    Friday, June 17, 2011 3:29 PM
  • Perfect. That solved the issue..

    Thanks a ton!!!!!

    Veena R


    Veena Raju
    Friday, June 17, 2011 3:35 PM
  • Out of curious to learn more about infopath.

    Can you tell me what you meant by "Infopath forms are associated with content types".

    Can you also give me some good links on "InfoPath 2010" learning materials(pdf docs).

     

    Thanks in advance

    Veena R


    Veena Raju
    Friday, June 17, 2011 3:36 PM
  • The default form is associated with the list itself, but if you create a new form you have the option to associate the form with a content type (especially if more than one CT exist). You will find short tutorials across the web or at http://blogs.msdn.com/b/infopath/ but if you need to master it, you should get a book (I believe there are at least 2 already published) and watch some intro training like those from Lynda - this will help you get the big picture as blog posts usually focus on certain technical issues.
    AK
    • Marked as answer by Veenar Friday, June 17, 2011 4:20 PM
    Friday, June 17, 2011 4:15 PM
  • Thanks a lot for the explanation given, its very clear. Which are the 2 books, can you give me the name. Whether it also covers from the basics?

     

    Thanks in advance

    Veena R


    Veena Raju
    Friday, June 17, 2011 4:18 PM
  • See this blog post for SP 2010 books in general. There seems to be 3 @ Amazon:
    nfoPath with SharePoint 2010 How-To
    Designing Forms for SharePoint and InfoPath: Using InfoPath Designer 2010
    InfoPath 2010 Cookbook: 101 Codeless Recipes for Beginners
    I looked at the first one and is good for beginners. Read customer reviews on Amazon for more info.
    AK
    Friday, June 17, 2011 5:21 PM
  • Thanks a lot

    Veena R


    Veena Raju
    Monday, June 20, 2011 12:47 PM
  • Looks like this is has been broken in SharePoint 2013 - RTM, at least on first testing on my new development box.

    When you select "Use the default SharePoint form" the new Item still points to "newifs.aspx"

    Yet to test on a second platform.

    Friday, December 7, 2012 8:08 AM
  • This revert to default from infopath still looks broken on 2013. Is there any update or work around available?
    Wednesday, December 25, 2013 7:44 PM