none
How to add the 'View All site contents' link using Powershell/Jquery RRS feed

  • Question

  • Hi

    We are migrating few site collections from SharePoint 2010 to SharePoint online, 

    While POC we saw that 'View All site contents' link was removed and is not visible.

    Is there any way to add the 'View All site contents' link explicitly using PowerShell or Jquery, we can only do it using the Client object model.

    Thanks in advance

    Paru


    Paru

    Wednesday, April 5, 2017 8:32 AM

All replies

  • "Site contents" is the equivalent of "View All Site Contents" in SharePoint Online.

    Wednesday, April 5, 2017 10:04 AM
  • Hi Even for some reason the "site contents" link in the Site Actions menu is missing for sites which have been migrated. Any way to add the link to the menu Using PowerShell or JQuery?

    Paru

    Wednesday, April 5, 2017 12:42 PM
  • Hi Paru

    Can you please provide the steps the SharePoint 2010 sites were migrated to SharePoint Online? 

    Thanks and Regards

    Reshmee

    Wednesday, April 5, 2017 2:51 PM
  • Hi Reshmee

    We are using ShareGate to migrate the sites, and the site content link disappears.

    Any idea why and how to get it back?

    Or else we can add that explicitly?

    Thanks 

    Paru


    Paru

    Thursday, April 6, 2017 8:31 AM
  • Hi Paru

    Can you see the other links "Site Settings", "App a Page" and "Add an app" from the settings clog icon?

    If you navigate to <site url>/_layouts/15/viewlsts.aspx, can you see the list of contents?

    Cheers

    Reshmee


    • Edited by reshmee011 Thursday, April 6, 2017 11:24 AM
    Thursday, April 6, 2017 11:24 AM
  • Hi Reshmee

    Thanks for the reply, yes i am able to see all other link and can access the url also, Site Contents link is missing from the 'Quick Launch' which we have at the last beneath the Edit links option, there was some confusion in requirement, regret the inconvenience.

    What can be the reason for the Site content link getting disappear from the Quick Launch after migrating the site.

    Thanks

    Paru


    Paru

    Friday, April 7, 2017 8:10 AM
  • Hi Paru

    I have never migrated SP2010 site to SPOnline directly. The reason could be the custom site/web template was used for the SP2010 site.

    To add the Site contents to the Quick Launch, you can use PnP cmdlet.

    Add-PnPNavigationNode -Title "Site Contents" -Url "/_layouts/15/viewlsts.aspx" -Location "QuickLaunch".

    More info about PnP PowerShell cmdlets can be found 

    https://github.com/SharePoint/PnP-PowerShell

    Cheers

    Reshmee

    Friday, April 7, 2017 4:13 PM
  • Hi <g class="gr_ gr_11 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="11" id="11">Reshmee</g>

    Thanks for sharing the link!

    Thanks

    Paru


    Paru

    Tuesday, April 11, 2017 12:32 PM
  • Hi,

    You can mark the helpful post as answer to help other community members find the helpful information quickly.

    If the issue still exists, you could provide the detail information if you would like further assistance.

    Best Regards,

    Lee


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, April 28, 2017 12:57 PM