none
Property Sync message missing in Result Types RRS feed

  • Question

  • I'm trying to customise some of the existing search result item templates.
    I've done it at the site collection level and can see the updates I made.

    I now want to include the item ID (ListItemID managed property) in the template.

    I've added the ListItemID to the ManagedPropertyMapping section of both item template as well as item hover panel template.

    This automatically updated the JS file based on the HTML file, but when I go to the Manage Result Types page there is no Property Sync alert (like here: http://stevemannspath.blogspot.co.uk/2013/03/sharepoint-2013-search-managed-property.html), which I am expecting to see at this point.

    I checked both pages - under Search and Site Collection Administration.
    I also checked the search centre (even though I'm not using it for this scenario).

    What's missing?
    Are there any pre-requisites required for this to work? (any features activated?)
    I remember doing this in the past on a different VM and it worked, now it doesn't.

    Wednesday, November 5, 2014 1:09 PM

All replies

  • Hi tsw_mik,

    According to your description, my understanding is that you want to know why the property sync alert not appear in your environment.

    I suggest you follow the steps of the articles below to achieve it.

    Here are some detailed articles for your reference:

    How to display values from custom managed properties in search results:

    http://blogs.technet.com/b/tothesharepoint/archive/2013/09/11/how-to-display-values-from-custom-managed-properties-in-search-results-option-1.aspx

    How to display values from custom managed properties in the hover panel in SharePoint Server 2013:

    http://blogs.technet.com/b/tothesharepoint/archive/2013/09/17/how-to-display-values-from-custom-managed-properties-in-the-hover-panel-in-sharepoint-server-2013.aspx

    Best Regards


    Zhengyu Guo
    TechNet Community Support

    Thursday, November 6, 2014 7:45 AM
  • Thanks Zhengyu

    That's the steps I followed, but I'm not seeing the Property Sync alert.

    Thursday, November 6, 2014 9:16 AM
  • Hi tsw,

    I suggest you check if you have something missing in the steps. You can refer the articles above.

    Best Regards


    Zhengyu Guo
    TechNet Community Support

    Monday, November 10, 2014 2:07 AM
  • Hi tsw,

    Did you have any updates ?

    Best Regards


    Zhengyu Guo
    TechNet Community Support

    Wednesday, November 12, 2014 9:33 AM
  • I went through the steps many times and compared with steps from other articles, I'm doing everything as in the article, but not getting the alert.

    Here are the simplified steps from the very beginning:

    1. Create new Team Site

    2. In SPD edit the Item_Default.js template in master page gallery and update it to:

    a) include ListItemID in ManagedPropertyMapping, like here:

      ctx['DisplayTemplateData']['ManagedPropertyMapping']={'ListItemID':['ListItemID'], 'Title':['Title'], 'Path':['Path'], 'Description':['Description'], 'EditorOWSUSER':['EditorOWSUSER'], 'LastModifiedTime':['LastModifiedTime'], 'CollapsingStatus':['CollapsingStatus'], 'DocId':['DocId'], 'HitHighlightedSummary':['HitHighlightedSummary'], 'HitHighlightedProperties':['HitHighlightedProperties'], 'FileExtension':['FileExtension'], 'ViewsLifeTime':['ViewsLifeTime'], 'ParentLink':['ParentLink'], 'FileType':['FileType'], 'IsContainer':['IsContainer'], 'SecondaryFileExtension':['SecondaryFileExtension'], 'DisplayAuthor':['DisplayAuthor']};
    

    b) include the ID at the bottom of the result, like here:

    ms_outHtml.push(''
    ,'            <div id="', $htmlEncode(itemId) ,'" name="Item" data-displaytemplate="DefaultItem" class="ms-srch-item" onmouseover="', ctx.currentItem_ShowHoverPanelCallback ,'" onmouseout="', ctx.currentItem_HideHoverPanelCallback ,'">'
    ,'				',ctx.RenderBody(ctx),''
    ,'                <div id="', $htmlEncode(hoverId) ,'" class="ms-srch-hover-outerContainer"></div>'
    ,'            </div>',
    'Item ID=',ctx.CurrentItem.ListItemID
    ); 
    

    3. Upload a test.txt file into the team site, run search crawl and search for that file

    The search result includes a text 'ID =', but no ID.
    The Property Sync message is not displayed either.
    Am I missing anything?

    • Edited by tsw_mik Thursday, November 13, 2014 5:26 PM
    Thursday, November 13, 2014 9:46 AM
  • Hi tsw-mik,

    If you have saved the display template, then when you go to Search Result Types, the Poroperty Sync Message should display.

    Best Regards


    Zhengyu Guo
    TechNet Community Support

    Tuesday, November 18, 2014 1:38 AM
  • After following those steps the message is not displayed in either:
    - Site Collection Administration / Search Result Types
    - Search / Result Types

    I tried that on two different SharePoint VMs already with the same result.

    Tuesday, November 18, 2014 9:24 AM
  • Any update on this? I am having the same issue.  and I have tried to update the display template multiple times but still don't get the message to update property sync.  
    Tuesday, April 7, 2015 4:25 PM
  • 2. In SPD edit the Item_Default.js template in master page gallery and update it to:


    You shouldn't update the .js file, but the .html template. The .js file will be updated automatically by SharePoint. But anyway, I'm updating .html template and sync alert doesn't appear in settings.
    Thursday, April 16, 2015 10:39 AM
  • I finally found a solution for this.

    If it doesn't appear to you, you can try to update it via powershell. The script from http://www.justinkobel.com/post/2013/03/29/Updating-Display-Templates-in-SharePoint-2013-Search

    $ssa = Get-SPEnterpriseSearchServiceApplication  
    
    $tenantOwner = Get-SPEnterpriseSearchOwner -Level SPWeb -SPWeb "https://dev.contoso.com/search/"
     
    Get-SPEnterpriseSearchResultItemType -Owner $tenantOwner -SearchApplication $ssa
     
    $ResultType = Get-SPEnterpriseSearchResultItemType -SearchApplication $ssa -Owner $tenantOwner | where-object { $_.Name -eq "ContosoResultType" }
     
    $ssa.UpdateResultItemType($ResultType)
    

    While updating built-in SharePoint Item_Person template I've got an error:

    Exception calling "UpdateResultItemType" with "1" argument(s): "built-in objects are immutable"

    So I created a copy of the result type and push update to a copy. And it works!

    By Microsoft documentation, you shold not change built-in templates...

    • Proposed as answer by Ignasi Tebé Tuesday, March 22, 2016 12:50 PM
    Thursday, April 16, 2015 11:02 AM
  • Thanks for providing the solution..

    I was trapped in it for a long time :)

    Thursday, September 24, 2015 10:59 AM
  • Thank you for your solution, Marek.

    I was becoming desesperated, and then you saved my day. Great advice!


    Tuesday, March 22, 2016 12:51 PM
  • Excellent troubleshooting skills
    Thursday, May 12, 2016 3:49 PM
  • Same issue here: the Property Sync doesn't appear.

    But I finally found a helpful blog post (https://www.cardinalsolutions.com/blog/2016/03/making-sharepoint-search-results-even-better-for-your-users) with detailled steps. I followed them, one by one, and it finally worked!

    I think the key thing is to use a copy of an existing Display Template. If I add the Managed Properties into the default Display Template, then the properties aren't available and the "Property Sync" message doesn't appear. However if I add some Managed Properties into a customized Display Template, then the "Property Sync" is visible and the same Managed Properties are also available in the default template!

    Thursday, May 18, 2017 2:14 PM
  • Thank you very much, I never thought about it that way before. This has solved many problems for us.

    Great Job:)


    Mohammad Ilyas

    Tuesday, March 13, 2018 9:25 AM