Static content not loaded in IE9 normal - loaded in every other browser and InPrivate mode


  • Config : SP2010 std SP1, TMG 2010 SP2, Win7, IE9. The site in question is a database attached and upgraded and initially working SP2007 contentDB with customized feature for rolling out V3 MasterPages.

    All browser load CSS and javascript, also IE9 when freshly installed. Als IE9 in InPrivate mode. After some time though (initially) a particular CSS file default.css from file based Styles library (not a document library) started failing. Seeing a 304 in Fiddler with emtpy body and returning nothing in the browser.

    Went up and down the Browser cache, TMG cache, IIS cache and Sharepoint blob cache - Went up and down XP/Win7 IE8 IE9 seemed to work on IE8, then this morning it worked on IE9 - some clicks later : Javascript not loaded - can not save list items, can not open site actions. Turn on InPrivate mode and it does work. Also compared all IE settings (both connections and advanced) this is not the problem.

    From the server without a hosts file - the site works fine. From my computer with a hosts file it also works fine. The TMG is in a DMZ, the SharePoint server in it's own domain. DNS settings have been checked in this domain.

    I'm in a seperate domain. Logging on with credentials checked again AD in the domain where SharePoint resides.

    There is clearly something with corruption of cache or maybe security concerning opening something from cache. The TMG cache is off - so take that out of your considerations.

    I will continue to examine IIS cache and file based location of files. I would appreciate any insights into this type of problem .. especially from MCMs ;-)


    I'm reading this on IE9 caching improvements - - Worth the read.

    UPDATE : On the IIS side running 7.5 - Three webapplications on 443, created on port 443, none on port 80. Only the default website in IIS is on port 80. There is a wildcard SSL terminating on an TMG 2010 SP2 and between the TMG and the SharePoint WFE IIS7.5 there is a dedicated SSL certificate.

    UPDATE2 I just removed the Timer Cache XML files, cachi.ini to 1 and started the timer service again. For whatever reason site actions and such are working, Ok button for adding new list items not and the CSS on my system master is not loading. 

    UPDATE3 We are back on testing TMG 2010 SP2. Current behaviour : without a hosts file entry.

    - When we click in IE9 on Win7 a title of a custom list item the javascript performing this and leading to the display page does not run

    - When on a list that has a grouped view the ungrouping shows loading for an indefinitate time (as javascript behind does not run)

    - After altering the hosts file I need to delete cache (do that from fiddler) and the links start working again (with a hosts file entry that is).

     UPDATE 4 - I see that the Javascript loading is for the Client Object Model - UI is V3 BTW - Looking thru some settings I come across this one ... at the web application level . This is not check marked, so should not be a problem .. but he there are not many stones left unturned.

    Client Object Model Permission Requirement

    You can require that the user must have the Use Remote Interfaces permission in order to use the Client Object Model to access the server. The Client Object Model is used by some parts of the UI. Enabling this prevents users from performing some tasks using the UI if they do not have the Use Remote Interfaces permission.

     UPDATE 5 - We did a TMG clean install - that works - so it seems TMG. We have an error 50 on the Scriptresource.axd leading to a HTTP status 500 in fiddler on protocol HTTPS. Googling this issue results in little concrete guidance.

    UPDATE  6 - We narrowed it down to the Web access policy and Web compression filter. Turning them on and off in turn has resulted in the required result. Turning the Web compression filter on seems to do the trick - but Why?

    See also this :


    • Edited by nicodejong Wednesday, December 14, 2011 2:24 PM
    Thursday, December 08, 2011 12:25 PM


All replies