none
Solver32 and 64 bit Excel

    Question

  • Im using Excel 64-bit. Solver used to work fine in Excel 2007, but now it shows:Run time error:54. File not found: Solver32.dll when trying to run the Solver after dialog input.

    Is solver uncompatible with 64-bit Excel?

     

    Wednesday, May 25, 2011 11:50 AM

All replies

  • Are you sure that the add-in was enabled?  Check via Excel Options ->Add-Ins...

    HTH,

    Eric

    Wednesday, May 25, 2011 12:45 PM
  • Yes, the dialog boxes shows as usual. After I press "Solve" it runs, but does not show any result. Only the error message.
    Wednesday, May 25, 2011 1:03 PM
  • This article http://msdn.microsoft.com/en-us/library/ff837594.aspx says that there's a 64 bit Solver included with 64 bit Excel, so your install may have deleted the Solver32.dll.  I'd check your add ins and see if you have the 64 bit version, disable the 32 bit, enable the 64 bit.  Just to check, do a search and see if you still have Solver32.dll somewhere on the PC.

    Cheers,

    Eric

    Wednesday, May 25, 2011 1:11 PM
  • Thanks, but does the 64-bit solver have another name, like "solver63.dll"?

    I have 2 solver-files in "C:\Program Files\Microsoft Office\Office14\Library\SOLVER"

    solver32.dll

    solver.xlam

    We have 3 computers with Excel 2010 64-bit. Fresh installed. So it cannot be only my install. It worked fine in Excel 2007.

    Thursday, May 26, 2011 8:29 AM
  • Hi,

     

    The reference file has the same name of SOLVER.XALM unregard of 64-bit or 32-bit. Please check this document:

    Using the Solver VBA Functions

     

    However, the reference file locates on different path.

    If your computer is 64-bit and the Office is 64-bit, the file locates at:

    C:\Program Files\Microsoft Office\Office14\Library\SOLVER\SOLVER.XLAM

    64-bit OS & 32-bit Office:

    C:\Program Files (x86)\Microsoft Office\Office14\Library\SOLVER\SOLVER.XLAM

     

    You can try to add reference to SOLVER.XALM manually to see if it will fix the issue.


    Best Regards, Calvin Gao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, May 26, 2011 12:15 PM
    Moderator
  • I checked now, and I only have one version of the file in C:\Program Files\Microsoft Office\Office14\Library\SOLVER\SOLVER.XLAM, so it must be the correct version. I tried to add a reference, but it did not help.

    Thursday, May 26, 2011 1:46 PM
  • Did you try to add a reference in VBA or did you check it as an active add-in in Excel?

    Thursday, May 26, 2011 1:51 PM
  • I tried both :)

    Same error.

     

    This code fails on last line:


        SolverOk SetCell:="$M$6", MaxMinVal:=3, ValueOf:=22, ByChange:="$L$6:$L$7", _
            Engine:=1, EngineDesc:="GRG Nonlinear"
        SolverOk SetCell:="$M$6", MaxMinVal:=3, ValueOf:=22, ByChange:="$L$6:$L$7", _
            Engine:=1, EngineDesc:="GRG Nonlinear"
        SolverSolve

     

    ? Err.Description
    File not found: Solver32.dll"

    Friday, May 27, 2011 6:37 AM
  • OK, I don't have the 64 bit version so I can't check anything.

    This article says you must have both the add-in enabled and the reference selected in the VB Editor: http://msdn.microsoft.com/en-us/library/ff196600.aspx  It shows you how to do it if you have what they expect are the 'usual' problems.  Your error indicates to me that either you haven't done both, or that one of the methods (and probably the VBA reference) is still pointed to the old version.  The only thing to do is to check that you've got the correct reference by surfing to the dll in the folder that Calvin pointed out above.

    Other than that, I think you've stumped everybody.  Sorry.

    Eric

     

    Friday, May 27, 2011 1:52 PM
  • Thanks Eric for your help

    File not found: Solver32.dll"

    Hi,

     

    How about the issue on your side now? I guess that the Slover32.dll corrupted in your computer. Have you check if the file “Slover32.dll” is existed under the subfolder of “C:\Program Files\Microsoft Office\Office14\Library\SOLVER”? As I delete the “Solver32.dll”, I got the same “File not fount: Solver.dll” error. See the illustration:

     

    So you can try to reinstall Excel (not whole Office) to see if the issue will be resolved.

     

    I look forward to hearing of you soon.


    Best Regards, Calvin Gao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Wednesday, June 1, 2011 6:28 AM
    Moderator
  • Sorry to bother again :)

     

    I tried to delete the solver32.* files, and did an Office 2010 repair using the built-in function in Office. The files were restored.

    But the problem prevails...

    Tuesday, June 7, 2011 10:42 AM
  • I had the same problem, and it was caused by an add-in that somehow modified the working directory.  Try the following:

    1. Enable the VBA/Developer tab.

    2. Go into COM Add-Ins under the Developer tab.

    3. Uncheck all of the boxes.

    4. Restart Excel.

    Then plug in some values for Solver and see if it fixes your problem.

    • Proposed as answer by Ruggermax Wednesday, May 11, 2016 1:07 PM
    Wednesday, February 22, 2012 10:09 PM
  • It did the same error for me and i copied the Solver.dll file in the %SystemRoot%\System32 folder and it worked!

    Hope it will work for you too!

    Jo

    • Proposed as answer by Marc Kh Thursday, April 9, 2015 11:03 PM
    Tuesday, April 8, 2014 9:52 PM
  • JoBne, thank you, your solution fixed it for me!

    Runtime error 53: solver32.dll not found. 

    Microsoft Office Excel 2013 X64 on Windows 7 x64.

    Thursday, April 9, 2015 11:03 PM
  • This worked for me as well. Thank you.....
    Wednesday, May 11, 2016 1:07 PM
  • worked for me as well, thanks

    - - -
    My situation:

    Runtime error 53: solver32.dll not found.
      after adding Solver via addin checkbox and trying to run Solver from Data/Analyze/Solver

    setup:
    Office 2016 (Office 365), Windows 10

    before fix:
    C:\Program Files (x86)\Microsoft Office\root\Office16\Library\SOLVER\
       files:
    SOLVER.XLAM
    SOLVER32.DLL

    After fix: (I left files in above, in addition:)

    C:\Windows\System32\
       file added:
    SOLVER32.DLL

    I then successfully ran Solver
    • Proposed as answer by Alexander Fan Thursday, April 20, 2017 2:52 PM
    Wednesday, July 20, 2016 12:17 PM
  • Worked for me as well!

    Wonder when will they fix it in an update.

    Sunday, August 28, 2016 3:05 PM
  • Thank you so much!  These very specific location directions helped me!
    Sunday, October 9, 2016 12:34 AM
  • Thanks! You save me! It also worked to office 2016!
    Monday, November 7, 2016 1:29 PM
  • This one worked for me. I had Webex productivity tool in the COM ADD-Ins enabled. Once i disabled. The solver worked for me. Thanks a lot.
    Tuesday, November 22, 2016 10:44 PM
  • So basically, what we have here is yet more incompetence shown by Microsoft developers. They're basically programming a 64 bit program to look in the 32 bit library (System32)!!! It would make more sense if 64 bit Excel looked in the SysWOW64 folder! But nope, we can't have sensible programming when we're buying from Microsoft. Unbelievable that they still haven't patched this either. Microsoft needs competition. Being a monopoly has caused them to be extremely sloppy.
    Saturday, December 3, 2016 6:25 AM
  • Thanks JoBne, your solution fixed it for me too!

    But I make a symbolic link in command prompt. Same result.

    mklink “C:\Windows\SysWOW64\solver32.dll“ “C:\Program Files (x86)\Microsoft Office\root\Office16\Library\SOLVER\SOLVER32.DLL”


    Thursday, December 22, 2016 6:13 PM
  • Thank you very much, JoBne and special thanks to Raisinasm, I was able to fix this problem on my very own (and in general I'm always drawing the "blond joker", since I am really far away from being an IT Pro). Now I am extremly proud on myself, though it's just because of Raisinasm's perfect, detailed description. Thanx again, you made my day.

    Tax



    • Edited by taxmaxx Friday, January 6, 2017 5:19 PM
    Friday, January 6, 2017 5:15 PM
  • Thank you, the solution is absolutely helpful.
    Thursday, April 20, 2017 2:53 PM
  • I tried that but it didn't help.
    Friday, July 28, 2017 6:50 PM
  • hola, yo fui a la carpeta en archivos de programa/ microsOffice/office15/library/solver y puse el acceso directo SOLVER.XLAM en escritorio, abro este primero luego una planilla excel cualquiera y ya, tengo solver.

    saludos

    Wednesday, November 22, 2017 4:10 AM
  • Thank you JoBne, after I tried all other solutions, yours finally fixed the problem. Thank you very much :)
    Sunday, June 24, 2018 12:41 PM