Access denied to Search Service Application


  • I just "upgraded" my installation of SharePoint 2010 Foundation with Search Server Express 2010.  During the installation, I was able to access and configure the Search Service Application.

    However, a day later, I cannot access the application management page: I get an access denied error.  I am the farm administrator, so supposedly I am supposed to have access to the management page.  I've also tried adding my login to the "Full Control" group of the Search Application; it gives me the same error.  It appears that the only account that can access the administration page is the service/system account.  Obviously this would not be ideal.

    I've tried looking around for logs to see if anything is amiss, but there appears to be nothing logged.

    What gives?  How do I fix it?

    Wednesday, September 01, 2010 2:31 PM

All replies

  • You can try this:

    CA> Application Management > Manage Service Applications > Select Search Express Service Application > On the ribbon select "Administrators" > Assign permissions as needed. You should then be able to access Search Express application management page.


    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    Wednesday, September 01, 2010 4:09 PM
  • I don't see that option....
    Wednesday, September 01, 2010 5:25 PM
  • What Search service options do you have?


    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    Wednesday, September 01, 2010 5:36 PM
  • If I select the Search Service Application option and click "Administrators" I can add users.  But there is no " Assign permissions as needed" option.



    Wednesday, September 01, 2010 6:05 PM
  • Sorry, I should make it clearer. " Assign permissions as needed" was a statement not a selection choice. Add users is the correct choice. Add users as needed. If you add yourself, you should be able to access the administration page.

    Hope this helps.

    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    Wednesday, September 01, 2010 6:14 PM
  • I already tried that. It didn't work.  Thought it might've been my account, so I added a different one.  Didn't work either.
    Wednesday, September 01, 2010 6:34 PM
  • Has anyone found an answer to this? 

    I also have the problem that only the system (farm) account can access the search application management page.   When clicking on Administrators in the ribbon the dialog states that Farm Administrators automatically have full control on all service applications, but none of them can access the search management pages.  Farm administrators can access other service management pages - just not the search application.

    Thursday, September 09, 2010 3:57 AM
  • Any update?
    Friday, September 17, 2010 7:02 PM
  • I have recently experienced the same problem. I think it may be tied to the removal of the initally created web application, then replacing it with a claims base application that is not fully configured for claims based authentication.
    Friday, September 17, 2010 8:07 PM
  • That jives with what I've done, which is I upgrading the default web application to use claims based authentication. This was done in order to better support the Office Web Applications (which don't support delegation under basic Windows authentication.)
    Friday, September 17, 2010 9:19 PM
  • Bump. Could MSFT or an MVP please assist?
    Wednesday, September 22, 2010 5:02 PM
  • Hi,

    Did someone find a solution? I give the full rights to my user (see image below) and we still have the same issue !!!!

    Friday, October 29, 2010 9:57 AM
  • i have same problem with my search service application that is not accessible even with Farm, service, Search accounts and getting "Access Denied" for page -->http://sharepoint:43966/searchadministration.aspx?appid=17612881-f0ce-4a4b-8f37-10981b00ac7d

    i found in windows event log : A database error occurred. Source: Microsoft SQL Server Native Client 10.0 Code: 4060 occurred 1 time(s) Description: Cannot open database "Search_Service_Application_DB_14e8093a755c41eaa59fb0ba94f9a421" requested by the login. The login failed. so i am looking into database permission using SQL server management studio.

    please assist.



    Vaibhav Jain SharePoint Solution Architect
    Saturday, November 20, 2010 10:41 AM
  • I have the same problem too.  I have installed SharePoint 2010 Foundation with Search Server Express 2010.  After creating the search service application I am prompted with "Access Denied" when trying to login using the Administrator account.  I have given the farm administrator account access to this service by clicking on the 'Administrators' button on the toolbar.  I have also tried creating a search service with the administrator account being the service account.  I haven't gotten anything to work.
    Sunday, November 28, 2010 10:09 PM
  • Hi,

    I found that i had installed sharepoint search express 2010 and for me that has created problem so simply i just uninstalled Fast Search express 2010 and then after it has started working without having problem of "Access Denied".

    I am still in investigation process of finding problem area that was generated due to FAST Search 2010.



    Vaibhav Jain SharePoint Solution Architect
    Monday, November 29, 2010 5:42 AM
  • Does someone have a solution?
    Tuesday, November 30, 2010 5:01 PM
  • Try below script, it should work to fix this issue as in claim based authentication you will see user name in this format -->                           'i: 0#.w|domain\user' is not the same as 'domain\user'.

    $site = new-Object Microsoft.SharePoint.SPSite(http://claimbasedauthsite)
    $wa = $site.WebApplication
    $user = "domain\user"
    $policy = $wa.Policies.Add($user, $user)

    Let me know if it works for you or not.



    Vaibhav Jain SharePoint Solution Architect
    • Proposed as answer by AlexOlivencia Tuesday, June 25, 2013 4:25 AM
    Tuesday, December 14, 2010 8:49 AM
  • Have a look at the SharePoint ULS logs, they might give you more info. Also check the Event Viewer. Make sure the Application Discovery service and the Secure Token Service are operating normally. Try with other service applications...

    Living the SharePoint dream...
    Tuesday, December 14, 2010 9:03 AM
  • The problem is not logging into the web application, but into the management page for certain services, after converting the main (non central administration) web application to use claims-based authentication.
    Friday, December 17, 2010 4:46 PM
  • We had similar issue when implementing ADFS SharePoint 2010. When converting webApp to any claim bases webapp, you should do the following two things.

    1. Do not convert service account such as crawling account.

    2. Setup different window based zone for the webapp with alternative access mapping.  Setup the crawling to crawl the window based alterative access URL.

    In this way, your crawling account will still use window authentication to crawl the webapp. We were able to get the crawling and searching working again.


    Hope this would help.

    Harry Chen



    Friday, March 04, 2011 5:56 AM
  • Does someone have a solution?
    I still have the issue !

    Tuesday, October 25, 2011 9:37 PM
  • I also still have this issue.

    I have come to a system which has been upgraded from Foundation search to Search Server express through to Search server.

    Our main web app is claims based but Central Admin is still NTLM.

    I have added myself as a Full Control Admin of the Search service application but clicking on the link gives me access denied and nothing useful in the ULS log.

    Any advice would be greatly appreciated.

    Thursday, November 03, 2011 9:23 AM
  • Wednesday, February 08, 2012 8:28 AM