none
PDF content search crawling Not working in multifarm -SharePoint 2010 Search/PDF RRS feed

  • Question

  • I have done the same steps as described at http://support.microsoft.com/kb/2293357 and Working fine in my Test Server (Single Farm) but it is not working yet in Production Server (Multifarm).

    My Production Servers are
    2 Front End Server (Server Farm 1 & Server Farm 2) running under NBL
    2 Storage (Clustered)

    I have check Crawl Log (PDF content is not crawling)

    Is there thing left to do?

    Any Help?

    Wednesday, April 24, 2013 1:14 PM

Answers

  • What are you using as your test pdf document?  Try deleting\re-adding it to ensure sharepoint picks it up as changed.  You could also reset the content index if your content base isn't too large.

    Nate

    • Marked as answer by M J Ferdous Friday, May 3, 2013 8:17 PM
    Friday, April 26, 2013 12:45 AM
  • Thanks Alex. I have applied your suggestions though I don't think this is a valid reason. 

    Anyway, Finally, I came up with the solution!! after considering all of your suggestion and others possibilities.
    Thanks to Everyone for your support. Let me explain here what are the steps taken additionally.

    Solution: 
    1. Configuring Adobe PDF iFilter 9 for 64-bit platforms http://support.microsoft.com/kb/2293357 except Re-Start Computer

    2. After installing the PDF iFilter, it is recommended that you set your system PATH environment variable to the "bin" folder of the "Ifilter" installation. For example, from the "Control Panel\System\Advanced\Environment Variables" tab, append to PATH "C:\Program Files\Adobe\Adobe PDF iFilter 9 for 64-bit platforms\bin\"
    and then restart the computer. Reference: http://www.adobe.com/support/downloads/detail.jsp?ftpID=4025

    3. Open Windows Explorer and navigate to the following location:
        C:\Program Files\Adobe\Adobe PDF iFilter 9 for 64-bit platforms\bin

    Add your Search Service Application’s Content Access Account to the list of users and groups who have security access to this folder.  Make sure the account has Read, Read & Execute, and List Folder Contents permissions

    4. Re-register the adobe iFilter dll using PowerShell

    regsvr32.exe"C:\Program Files\Adobe\Adobe PDF iFilter 9 for 64-bit platforms\bin\PDFFilter.dll"

     

    5. Restart the SharePoint Server Search 14 in Every Farm (Enable/Run if  Server Search 14 is Disable in other Server Farm)

    6. Reboot the SharePoint servers in Farm

    7. Reset the content index (Optional)

    8. Start Full Crawling

    Cheers!!
     


    MJ Ferdous SharePoint Architect | BrainStation-23 http://geekswithblogs.net/ferdous

    • Marked as answer by M J Ferdous Friday, May 3, 2013 8:08 PM
    Friday, May 3, 2013 8:07 PM

All replies

  • In your multi server environment where did you install the PDF iFilters?  If the iFilter isn't on the right server it won't index the content.  also check to make sure you didn't miss the step where you add PDF as a file extension to be crawled.

    Wednesday, April 24, 2013 1:20 PM
  • I believe that i have done all steps correctly. 
    I have installed PDF iFilter in both front end server. Do i need to install it in DB Server?

    Yes i also added pdf file extension. Moreover, I have configured in the single Farm Environment which is working. I am not sure if there is any Multi-Server Environment Issue that i left. Let me know if you have any idea?


    MJ Ferdous

    SharePoint Architect | BrainStation-23

    http://geekswithblogs.net/ferdous



    • Edited by M J Ferdous Thursday, April 25, 2013 4:21 AM
    Thursday, April 25, 2013 2:08 AM
  • What are you using as your test pdf document?  Try deleting\re-adding it to ensure sharepoint picks it up as changed.  You could also reset the content index if your content base isn't too large.

    Nate

    • Marked as answer by M J Ferdous Friday, May 3, 2013 8:17 PM
    Friday, April 26, 2013 12:45 AM
  • You need to follow these steps on every server in the farm

    http://support.microsoft.com/kb/2293357?wa=wsignin1.0


    MCITP-EA | "You don't understand anything until you learn it more than one way" | Hope This Helps!

    Friday, April 26, 2013 1:01 AM
  • To add to the above, have you checked the search logs in the search administration page. That may give you some pointer as to what's happening and why the result isn't being returned.
    Friday, April 26, 2013 7:01 AM
  • Hi NateJacobs,

    I have re-set the content index. Bur I see it Search in The Library Item but doesn't crawl pdf files inside. And there is no error. See the following Image where "Knowledge Center" is the Library

    Let me me know if you have any solution. Thanks.


    MJ Ferdous SharePoint Architect | BrainStation-23 http://geekswithblogs.net/ferdous

    Thursday, May 2, 2013 10:40 AM
  • Are the files visible in the allitems.aspx view? Also are you crawling the allitems.aspx page?

    I've seen search issues where the files were never being indexed because a crawl rule blocked the default view and where there weren't any other views in use nothing in those libraries was crawled...


    To make sure your PDF is crawled you need to have at least one view within which that pdf should be visible.
    Thursday, May 2, 2013 11:21 AM
  • Thanks Alex. I have applied your suggestions though I don't think this is a valid reason. 

    Anyway, Finally, I came up with the solution!! after considering all of your suggestion and others possibilities.
    Thanks to Everyone for your support. Let me explain here what are the steps taken additionally.

    Solution: 
    1. Configuring Adobe PDF iFilter 9 for 64-bit platforms http://support.microsoft.com/kb/2293357 except Re-Start Computer

    2. After installing the PDF iFilter, it is recommended that you set your system PATH environment variable to the "bin" folder of the "Ifilter" installation. For example, from the "Control Panel\System\Advanced\Environment Variables" tab, append to PATH "C:\Program Files\Adobe\Adobe PDF iFilter 9 for 64-bit platforms\bin\"
    and then restart the computer. Reference: http://www.adobe.com/support/downloads/detail.jsp?ftpID=4025

    3. Open Windows Explorer and navigate to the following location:
        C:\Program Files\Adobe\Adobe PDF iFilter 9 for 64-bit platforms\bin

    Add your Search Service Application’s Content Access Account to the list of users and groups who have security access to this folder.  Make sure the account has Read, Read & Execute, and List Folder Contents permissions

    4. Re-register the adobe iFilter dll using PowerShell

    regsvr32.exe"C:\Program Files\Adobe\Adobe PDF iFilter 9 for 64-bit platforms\bin\PDFFilter.dll"

     

    5. Restart the SharePoint Server Search 14 in Every Farm (Enable/Run if  Server Search 14 is Disable in other Server Farm)

    6. Reboot the SharePoint servers in Farm

    7. Reset the content index (Optional)

    8. Start Full Crawling

    Cheers!!
     


    MJ Ferdous SharePoint Architect | BrainStation-23 http://geekswithblogs.net/ferdous

    • Marked as answer by M J Ferdous Friday, May 3, 2013 8:08 PM
    Friday, May 3, 2013 8:07 PM