none
SharePoint Designer 2013 Workflow Platform is not available RRS feed

  • Question

  • I have followed all the steps in Installing and configuring workflow for SharePoint 2013:

    http://technet.microsoft.com/en-us/library/jj658588.aspx

    I have gone through all the validation steps of making sure all the services (service bus, workflow back end, etc.) are running, and the SharePoint service application says it is connected.  I've checked the Microsoft-Workflow event viewer logs, and I don't have any errors.

    However, after I connect to my SharePoint 2013 site with SharePoint Designer 2013, I get the following error when trying to create a 2013 workflow:

    "The option for the SharePoint 2013 Workflow platform is not available because the workflow service is not configured on the server. Please contact your server administrator."

    Any suggestions?

    Wednesday, March 20, 2013 8:24 PM

Answers

  • Thanks for your reply!

    I did make sure to register the Workflow Service with the sets you linked to.  I tried a few different option with and without force.  I've also checked the proxy as well.  I'm building a new, clean 2013 environment and see if there is something else at play.

    Thursday, March 21, 2013 7:08 PM

All replies

  • I'm assuming you registered the workflow service as described in Installing and configuring workflow for SharePoint Server 2013 ......

    If so, you want to ensure you used the correct Management Shell Cmdlet.

    This happened this morning while setting up our SPS 2013 EE production environment with Eugene Rosenfeld; we registered the workflow using; Register-SPWorkflowService –SPSite "http://myserver/mysitecollection" –WorkflowHostUri "http://workflow.example.com:12291" –AllowOAuthHttp

    This the cmdlet for communicating over http; our environment communicates over https. I received errors when trying to publish 2013 Workflows from SPD 2013.... You can check your environments setting by running; Get-SPWorkFlowConfig -webapplication http://sitename

    If it is incorrect,  Eugene found there is no cmdlet you can run to remove it (or rather didn't find one), instead he wrote here What's The Opposite of Register-SPWorkflow ; "The closest I've been able to find is to run the Register-SPWorkflowService command with the -Force parameter. That at least allows you to change the workflow registration for a site collection.  Register-SPWorkflow Service "

    HTH

    -Eugene Rosenfeld
     Black Blade Inc.

    So if you're communicating via https and you find that it was registered for http try running this cmdlet; Register-SPWorkflowService -SPSite 'https://myhost/mysite' -WorkflowHostUri 'https://workflowhost' -Force

    Also, in Central Admin under Manage Service Applications; ensure Workflow Service Application Proxy was created. -bill

    Thursday, March 21, 2013 2:02 AM
  • Thanks for your reply!

    I did make sure to register the Workflow Service with the sets you linked to.  I tried a few different option with and without force.  I've also checked the proxy as well.  I'm building a new, clean 2013 environment and see if there is something else at play.

    Thursday, March 21, 2013 7:08 PM
  • Good Luck, let us know how it turns out!
    Friday, March 22, 2013 1:05 AM
  • Did you try a clean installation? how did you get on.

    I am facing exactly the same issue, i have configured everything and got the "Workflow is connected" message in the Workflow Service Application but still I cannot get 2013 workflows available in Sharepoint designer 2013....

    Very frustrating, can anyone assist??

    Thanks in Advance

    Tuesday, June 18, 2013 2:00 PM
  • Hi,

    I am also facing the same issue, tried all the solution mention in the forum, tried even un installing and installing the worklflow manager. But no help.

    Any Help ???

    Thanks


    regards Vimal

    Wednesday, June 19, 2013 8:11 AM
  • I am also facing the same issue. 

    Anybody???

    Shawn

    Wednesday, June 19, 2013 6:59 PM
  • I am in the same situation

    Any updates on this?

    Friday, August 23, 2013 7:25 PM
  • Hi,

    Even I faced the same issue previously. though workflow manager and all other stuffs were configured properly i was not able to see SP2013 Workflows in sharepoint designer as well as in other list and libraries.

    Solution : whenever a new workflow service application proxy is created in SP2013, by default it will not be associated(service connection) with any web application. Go to Central admin site->Manage web applications

    page -> Select the web app which was registered earlier during configuration and check " workflow service application proxy" and click OK

    Hope this will solve the issue,

    Regards,


    • Proposed as answer by JmATK Friday, December 27, 2013 10:52 AM
    Tuesday, December 24, 2013 5:33 AM
  • JmATK's method worked for me! Thanks!
    Friday, January 24, 2014 9:16 PM
  • How is this marked as an answer?
    Tuesday, April 1, 2014 4:15 PM
  • Had the same issue, tried all the fixes listed here and on other forums but nothing worked.  Everything looked OK from SharePoint Server but SPD 2013 was still giving the same error.

    Tried running windows updated a couple of times to pull them all in and hey presto!

    Wednesday, July 9, 2014 12:03 PM
  • I had the same problem, but it solved after running SharePoint 2013 Products Configuration Wizard

    after register the Workflow to site.


    Mustafa


    Monday, March 30, 2015 4:18 PM
  • Hi,

    It is old thread but I know when we had this issue we visit this url so, worth to share my experience on this.

    We had the similar issue and I struggled around 20 hours to see one extra  item in SharePoint designer workflow dropdown list  J

    The option for the SharePoint 2013 workflow platform is not available because workflow service is not configured on the server”

    Ti fix go to Central Admin – System setting – check the services on server- make sure that below given two services are running on all Servers.

    Microsoft SharePoint Foundation Subscription Settings Service

    App Management Service

    To see the SharePoint Workflow 2013 platform in SharePoint designer we did everything, all the things we checked and tried to nail down but issue was above mentioned services


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    Saturday, July 16, 2016 10:04 PM
  • I want to share my experience. I was in the absolutely same trouble, as OP. I checked everything that I could find, but all options looks liked fine. In my case, this commandlet was helped me:

    Enable-SPFeature
    -Identity WorkflowServiceStore –Url $yourUrl

    You can find this hint in some blogs, where blogers state that $yourUrl - your site collection URL. However, and this the key point in my case, $yourUrl isn't just site collection URL, but also may be a web URL, so mentioned feature may be activated on the web-level also. E.g.

    Enable-SPFeature -Identity WorkflowServiceStore –Url https://site/test

    Hope, this will help someone else.

    Sorry for my poor English.

    • Proposed as answer by mcantin Wednesday, June 5, 2019 2:58 PM
    Friday, August 12, 2016 8:45 AM