none
search shows results but 1 result is linked to wrong file (pdf) RRS feed

  • Question

  • We posted an article with the name NIMUDEN NPR-4-M.pdf. We also posted (in the past) some items with the name NIMUDEN NPR-4-D.pdf and NIMUDEN NPR-4-A.pdf, ...

    When we go straight to the correct menu where we see the pdf and click on the pdf we see the correct content of the pdf. So NIMUDEN NPR-4-M.pdf is showing the content of NIMUDEN NPR-4-M.

    When we search in the sharepoint site (looking for NUMIDEN) we see all the pdf files with NUMIDEN. But, now it comes, the found result for NIMUDEN NPR-4-M.pdf is showing the article NIMUDEN NPR-4-D.pdf behind it.

    See also screenshots.

    I already tried to remove the NIMUDEN NPR-4-M.pdf and add it again but the result page keep showing the same.

    What can I do about it? Many thanks for your feedback.

    Regards

    Kurt 

    Thursday, February 14, 2019 1:48 PM

Answers

  • Hi Kurt:

    To reset the index:

    Go to CA-> Manage service applications-> Search Service Application-> Index Reset in the Crawling section.

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by IRCKurt Tuesday, February 19, 2019 10:42 AM
    Friday, February 15, 2019 10:00 AM
  • Hi Kurt,

    To remove the search result, you could go to CA-> Manage service applications-> Search Service Application-> Search Results Removal in the Queries and Results section, type the urls you want to remove  from search results.

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by IRCKurt Tuesday, February 19, 2019 10:42 AM
    Tuesday, February 19, 2019 8:51 AM

All replies

  • Hi

    Does your crawler run after you change the file?


    Justin Liu Office Apps & Services MVP, MCSE
    Senior Software Engineer
    Please Vote and Mark as Answer if it helps you.

    Friday, February 15, 2019 2:17 AM
  • For the good order: I am not really familiar with sharepoint and it is a case we have to take over. But that said...

    I went to the crawler and started an incremental. I will let it run and if stopped I' ll do a search test and post the results here again.

    BTW: thanks for replying, Justin!

    Kind regards

    Kurt 

    Friday, February 15, 2019 7:40 AM
  • Justin,

    The crawl indexing has ended. But the search is the same: looking for "Nimuden NPR-4-M" gives an url which shows the wrong document link.

    Any other ideas?

    Kind regards

    Kurt

    Friday, February 15, 2019 8:43 AM
  • Hi Kurt,

    Have you tried to run a full crawl?

    If possible,you could reset the index and start a full crawl again to see if this issue still happens.

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.


    Friday, February 15, 2019 9:09 AM
  • Thanks Michael for replying!

    I have to look it up how-to-reset-the-index but I did start a full crawl now. It will run for a while, I think.

    If that does not help, I will reset the index and do a full crawl again.

    To reset: is there a clear procedure I can follow?

    Kind regards

    Kurt

    Friday, February 15, 2019 9:43 AM
  • Hi Kurt:

    To reset the index:

    Go to CA-> Manage service applications-> Search Service Application-> Index Reset in the Crawling section.

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by IRCKurt Tuesday, February 19, 2019 10:42 AM
    Friday, February 15, 2019 10:00 AM
  • Ok, I did a full reset and then a full crawl.

    the results are better = it shows the correct link, BUT it still shows the wrong link also!

    Can I now disable that result? So only the correct link stays?

    see screenshot.

    kind regards

    Kurt

    Tuesday, February 19, 2019 7:56 AM
  • Hi Kurt,

    To remove the search result, you could go to CA-> Manage service applications-> Search Service Application-> Search Results Removal in the Queries and Results section, type the urls you want to remove  from search results.

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by IRCKurt Tuesday, February 19, 2019 10:42 AM
    Tuesday, February 19, 2019 8:51 AM
  • After removing the link and doing a new crawl the results were fully ok.

    no faulty link anymore and the search gave all the correct documents for nimuden.

    thank you very much for all your help!!!

    Tuesday, February 19, 2019 10:42 AM