none
Add-Ins not loaded. A runtime error occurred during the loading of the COM Add-In. RRS feed

  • Question

  • Please I need help to understand why my Add-in is not been loaded by excel. I checked in Registry Editor, HKEY_CURRENT_USER/Software/Microsoft/Office/ Excel/Addins/Ribbon and the LoadBehavior key is 3.

    Where can I find more additional information about the possible cause of this problem?


    robert hellestrae

    Monday, April 1, 2013 9:56 PM

Answers

  • Hi Robert,

    Thank you for posting in the MSDN Forum.

    I think you can refer the article below which shows various reasons on addin load failure.

    My Office Addin does not Load!

    Hope it helps.

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by rrobhelle Monday, April 8, 2013 5:13 PM
    Thursday, April 4, 2013 4:17 AM
    Moderator
  • Hi Quist,

    I've the same runtime error but find no way to further trace it.

    The COM Add-In is not developed by me, it's the add-in offered by box.com, named "Box.MSExcel_AddIn.vsto". I've post this issue to their forum, however, their developer said this is microsoft issue, not their addin issue. My God, how good the support I received from this free add-in!

    Back to this issue, I tried below:

    Set the "VSTO_SUPPRESSDISPLAYALERTS" environment variable to 0

    But fail to get any error message.

    I tried to load Excel Addin, like Analysis ToolPak and Conditional Sum Wizard, without any problem. But the COM Addin, Box.MSExcel_AddIn, I can get this only: “Load Behavior: Not Loaded. A runtime error occurred during the loading of the COM Add-in”.

    My platform: Windows XP SP3, Office 2007, .Net platform 4, VS2010 Tools for Office Runtime (x86) 10.0.3107

    In addition, I try to create a testing vbs with below code:

    Set o = CreateObject("Box.MSExcel_AddIn.vsto")

    It results with error Code 800A01AD - ActiveX component can't create object ''Box.MSExcel_AddIn.vsto"

    Please kindly suggest.

    Regards,

    Adrian

    • Marked as answer by rrobhelle Wednesday, August 7, 2013 1:32 PM
    Sunday, May 19, 2013 12:31 PM

All replies

  • Hi Robert,

    Thank you for posting in the MSDN Forum.

    I think you can refer the article below which shows various reasons on addin load failure.

    My Office Addin does not Load!

    Hope it helps.

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by rrobhelle Monday, April 8, 2013 5:13 PM
    Thursday, April 4, 2013 4:17 AM
    Moderator
  • Hi Quist,

    I've the same runtime error but find no way to further trace it.

    The COM Add-In is not developed by me, it's the add-in offered by box.com, named "Box.MSExcel_AddIn.vsto". I've post this issue to their forum, however, their developer said this is microsoft issue, not their addin issue. My God, how good the support I received from this free add-in!

    Back to this issue, I tried below:

    Set the "VSTO_SUPPRESSDISPLAYALERTS" environment variable to 0

    But fail to get any error message.

    I tried to load Excel Addin, like Analysis ToolPak and Conditional Sum Wizard, without any problem. But the COM Addin, Box.MSExcel_AddIn, I can get this only: “Load Behavior: Not Loaded. A runtime error occurred during the loading of the COM Add-in”.

    My platform: Windows XP SP3, Office 2007, .Net platform 4, VS2010 Tools for Office Runtime (x86) 10.0.3107

    In addition, I try to create a testing vbs with below code:

    Set o = CreateObject("Box.MSExcel_AddIn.vsto")

    It results with error Code 800A01AD - ActiveX component can't create object ''Box.MSExcel_AddIn.vsto"

    Please kindly suggest.

    Regards,

    Adrian

    • Marked as answer by rrobhelle Wednesday, August 7, 2013 1:32 PM
    Sunday, May 19, 2013 12:31 PM
  • try this link for additional insight, guidance - http://blogs.msdn.com/b/haahmadi/archive/2010/05/26/my-vsto-add-in-does-not-load.aspx

    robert hellestrae

    Wednesday, November 4, 2015 10:00 PM