none
Scope Not found error while registering Workflow service on windows Server 2016 DataCenter RRS feed

  • Question

  • 'm facing Scope '/SharePoint' not found error while running Register-WorkflowService command on my SharePoint 2016 machine which is running on Windows server 2016 datacenter. Farm is single server.

    Below are the further system details. All the installations are done offline instead of webplatform installer

    • Workflow Manager - 1.0 cumulative update 5 - KB4055730
    • Service Bus 1.1
    • SQL Sever 2016 - Ran compatibility level update script as per pre-requisite for CU5

    I can access my workflow manager site on both http and https while running IE as admin. 

    I've verified my SharePoint site also

    The service account used is Farm account which has admin access on system also.

    Any help would be much appreciated as I have been stuck on this issue for past few days.

    Monday, March 30, 2020 7:18 PM

All replies

  • Is your workflow farm is connected to the SharePoint farm ? If it is then try using below script to get the scope of your farm.

    Add-PSSnapin "Microsoft.SharePoint.PowerShell"
    $site = Get-SPSite https://sharepoint.cobaltatom.com
    $proxy = Get-SPServiceApplicationProxy | ?{$_.TypeName -eq 'Workflow Service Application Proxy'}
    $proxy.GetHostname($site)
    $proxy.GetWorkflowScopeName($site)
    Thanks & Regards,

    sharath aluri

    Monday, March 30, 2020 7:39 PM

  • Thank you for the response Sharath. I've tried the command but response is empty for getscopename. Also observed in my SQL WFResourceManagmentDB, there is only one entry of scope in 'Scope' table whose RootPath is '/' and there is no 'SharePoint' scope. I think issue is because of SQL2016 and Server 2016 Data Center as same steps worked for me on SP2013 machine. Are there any extra steps to be done for 2016?

    Thank you,

    Anandh

    Tuesday, March 31, 2020 4:07 PM
  • I don't think so, Configuring Workflow Manager is same for SharePoint 2013 and SharePoint 2016. Just make sure you configure Workflow Manager CU4 (preferably CU5) is supported with SQL Server 2016 and Windows Server 2016. You might have to reconfigure workflow manager again

    Thanks & Regards,


    sharath aluri

    Tuesday, March 31, 2020 4:35 PM