none
Error: To export a list, you must have a microsoft sharepoint foundation-compatible application

All replies

  • Do you have Office 2013 or Office 2016?

    If you do then click ok on the prompt. It should then open another prompt to how you have your downloads set up. and then you should be able to open it.

    Friday, March 17, 2017 11:25 AM
  • Hi Venkatzeus,

    Please ensure you are using 32-bit versions of Internet Explorer.

    If you are using windows 7 64 bit, then you will get both 32 bit and 64 bit version of Internet Explorer installed on your computer. Navigate to C:\Program Files (x86)\Internet Explorer\iexplore.exe to use Internet Explorer 32 bit.

    Meanwhile, make sure the Web Client service is started.

    Enable Compatibility View in Internet Explorer, check if it works.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, March 20, 2017 12:12 PM
    Moderator
  • Hi,

    You need to install the Micrsoft Access Database Engine"( Download here) driver on your machine, where you are trying to export to excel or DataSheetview.

    If you have already installed this driver, then you look into your browser supporting the active X control.

    Absolutely you have to use the 32 bit only as suggested by Linda, this problem happening only on the machine with 64bit Of Office Product installed.


    Please remember to click Mark as Answer on the answer if it helps you

    Monday, March 20, 2017 3:53 PM
  • Hi.

    If you're seeing this on all lists, then i recommend running a repair on MS Office. 

    If it's just this list, I'm not sure if it will have any affect.

    Hope this helps.

    Ed

    Monday, March 20, 2017 8:37 PM
  • Worked for me! Thanks Linda
    Sunday, May 21, 2017 11:53 PM
  • Hi Venkatzeus,

    Please ensure you are using 32-bit versions of Internet Explorer.

    If you are using windows 7 64 bit, then you will get both 32 bit and 64 bit version of Internet Explorer installed on your computer. Navigate to C:\Program Files (x86)\Internet Explorer\iexplore.exe to use Internet Explorer 32 bit.

    Meanwhile, make sure the Web Client service is started.

    Enable Compatibility View in Internet Explorer, check if it works.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    That's good for Windows 7.  How is this fixed in Windows 10? 
    Tuesday, November 14, 2017 5:10 PM