none
Completed tasks no longer complete in Project Server RRS feed

  • Question

  • I have a schedule in Project Server 2010, and there are about 5 tasks that keep losing their % complete.

    They are marked as 100% complete with finish dates in the past, I publish the schedule to Project Server and check in. 

    A week later those tasks that were 100% complete are now back to zero %. 

    I've only noticed it in 1 of our many schedules that we have on the Server.

    Has anyone seen this before?

    Thanks!


    • Edited by MikeStout Wednesday, July 11, 2012 6:40 PM
    Wednesday, July 11, 2012 6:39 PM

All replies

  • Hi Mike,

    At what point does this happen, after accepting updates in to the project plan? Or do you progress / update tasks manually? Is the remaining work set to 0?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Wednesday, July 11, 2012 6:48 PM
    Moderator
  • Hi Paul,

    We recieve updates from resources through PWA on a daily basis.  But for these particular tasks we updated them in Project Pro.  There is no work assigned to the tasks, remaining work and remaining duration field is zero when we mark them complete.  Last week I marked them complete again, checked on a daily basis and status was still there.  This week when I pulled up the schedule the status was once again gone.  I'm not 100% sure, but it seems to be happening over the weekend.

    thanks,

    Mike

    Wednesday, July 11, 2012 6:58 PM
  • Hi Mike,

    What is the history to these tasks, were there resources assigned at one point maybe? What happens over the weekend? Any custom scheduled jobs / tasks?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Wednesday, July 11, 2012 7:10 PM
    Moderator
  • There is 1 resource assigned to each task, it's the same resource that has always been on there.

    I know there are some custom schedule jobs that run over night, and possibly some on the weekend.

    I just find it odd that it's only doing this to 1 schedule (that we've noticed).  I've tried removing it from the Server and republishing, but still have the same problem.

    thanks,

    Mike

    Wednesday, July 11, 2012 7:59 PM
  • Hi Mike,

    Once this has reverted back, what does the assignment details show for this one resource, for example - split the view on Project Pro with the Gantt at the top and Task Usage below. Click the task in the Gantt view and check the assignment row details in the task usage view. Check the %work complete, actual work etc.

    There will be something triggering this change, as a test set the task to 100 % complete, 0 remaining work etc. and confirm the assignment details match. Save and publish the project plan. Then ask the resource to submit the their timesheet / Task updates. Open the plan and see if the % complete has changed..

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Thursday, July 12, 2012 6:36 AM
    Moderator
  • Hi Paul,

    I went to the resource and had them update the task via PWA. There was an actual start date already populated in their My Tasks view for those tasks, even though it was showing 0% complete.

    Hopefully having them update in PWA will fix this problem.  I will check the schedule on Monday to see if the tasks are still 100%.

    Thanks for your input on this! I'll keep you posted.

    -Mike

    Friday, July 13, 2012 2:57 PM
  • Also if you have the setting to only allow updates from PWA then any changes from Pro get backed out when you save.  Could it be this behavior that is doing this?  It will give you a warning message but perhaps it isn't clear exactly what it is warning about.

    Let us know how the tests go.

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Friday, July 13, 2012 9:35 PM
    Owner
  • The tasks that I had the resource update via PWA on Friday are still at 100% complete.                                         So, that was a success.  I still want to figure out why it's only doing this for some tasks. 

    I'm able to status other tasks in Pro, that have resources assigned, and they stay marked 100%. 

    I have some other tasks in this schedule that I'm having trouble with.  I deleted the resource and marked the task 100% complete.  I will keep checking the rest of the week to see if those tasks stay at 100%.  If that works perhaps there's something going on with the resources, and Project Server isn't allowing those tasks to be marked complete because those resources were/are not available to perform work at that time.  I don't have leveling turned on, so I wouldn't think it would do that.

    Also, I checked the settings and it's not set up to only allow updates from PWA.

    Either way, I'm making some progress and I'll keep researching and trying new ideas.

    Thanks!

    Mike


    • Edited by MikeStout Wednesday, July 18, 2012 3:03 PM
    Wednesday, July 18, 2012 3:02 PM
  • HI Mike,

    you may also want to close the tasks for update.You can find this feature in the server settings. It essentially means that no resource can update the task via PWA. would that would do is ensure that the task is not changed anymore in PWA. Maybe that helps

    Marc


    Marc Soester [MVP] http://marcsoester.blogspot.com

    Thursday, July 19, 2012 11:15 PM
    Moderator
  • we see this often.  It is most often related to tasks that are fixed duration (effort driven = off) and either where the work in the task has been updated to end prior to the task finish date or when a task has been split.  Generally, changing the task type to "fixed work" resolved the % complete "reset".  It will shorten the duration of the problme task to encompass only the dates that had work on them, which may affect successor task dates, so watch for date chnages.
    Monday, August 19, 2013 12:41 PM