none
Anonymous Site page and Authorized site page on same web portal by share point technology 2013. RRS feed

  • Question

  • Hi,

        
    "I want to use Anonymous Site page and Authorized site page on same web portal by share point technology 2013.
    In details, I have an web portal, in which user will login by proper authorization only, but I also needed a Survey related site page on my web portal, which will open without any authentication by all public zone.
    when I creates Anonymous Site page for my Survey Application on the web portal, then Authentication also failed for Authorized site pages, and any unauthorized user can see secured or non shared data.

    Pls suggest me, How I can manage, Anonymous Site page and Authorized site page on a single web portal."

    Thanks

    Mukesh


    Thanks Mukesh

    Thursday, October 6, 2016 12:27 PM

Answers

  • In your portal site, Enable Anonymous Access only for Lists and Libraries. This can be done via Site Actions --> Site Settings --> Site Permissions. (Remember, here the Anonymous Access option will appear in the ribbon only after you have enabled anonymous access at the web application level.) Once you do this also, you have to go to your individual list / library, where your page is going to reside, turn on the View Access for pages (for libraries, you can only turn on View access), from the Library Settings - Permissions for this document library. Please note that Anonymous access will be shown on the Ribbon only if you click on Stop Inheriting Permissions). Since you want to enable only for one page, turn off the anonymous access for all other pages using PS or through code. Hope it helps.

    Ven

    Friday, October 7, 2016 5:24 AM
  • Hi Mukesh,

    You need to put this the page into a library and then set the anoymous access enabled for the single library.

    Here is a similiar thread for your reference:

    Give anonymous users access to only one page on SharePoint Site

    More information about set anoymous access for library, please check:

    Anonymous Access in SharePoint 2013

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, October 7, 2016 6:12 AM

All replies

  • In your portal site, Enable Anonymous Access only for Lists and Libraries. This can be done via Site Actions --> Site Settings --> Site Permissions. (Remember, here the Anonymous Access option will appear in the ribbon only after you have enabled anonymous access at the web application level.) Once you do this also, you have to go to your individual list / library, where your page is going to reside, turn on the View Access for pages (for libraries, you can only turn on View access), from the Library Settings - Permissions for this document library. Please note that Anonymous access will be shown on the Ribbon only if you click on Stop Inheriting Permissions). Since you want to enable only for one page, turn off the anonymous access for all other pages using PS or through code. Hope it helps.

    Ven

    Friday, October 7, 2016 5:24 AM
  • Hi Mukesh,

    You need to put this the page into a library and then set the anoymous access enabled for the single library.

    Here is a similiar thread for your reference:

    Give anonymous users access to only one page on SharePoint Site

    More information about set anoymous access for library, please check:

    Anonymous Access in SharePoint 2013

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, October 7, 2016 6:12 AM