none
Search no longer working. Only returns "We did not find any results for examplesearch." RRS feed

  • Question

  • Hi

    We tried changing our sharepoint site from using http, to https. Since removing the binding in iis for port 80, and changing the website addressing in central administrator>app management>configure alternate access mappings, our search function is no longer working. 

    Under the document library there are hundreds of documents, if I attempt to search for a doc, even specifying 'This site' it always returns the same:

    We did not find any results for exampledocname.

    This is urgent for us, so any quick help or suggestions are welcome.

    Kind regards

    G

    Tuesday, October 23, 2018 7:50 AM

Answers

  • I have now resolved everything with this. It was due to a setting in iis that had not been set for the CRL. I found the answer to the issue at the bottom of this article:

    https://knowledge.zomers.eu/misc/Pages/How-to-publish-Active-Directory-Certificate-Services-Certificate-Revocation-List-on-the-internet.aspx

    Turning on 'Allow double escaping' solved this.

    To get to this I used a mixture of fiddler and certutil -URL "http://crl.domain.com Issuing CA.crl", which showed me the CDP had failed, but I was able to download and resolve this as mentioned previously in a browser.

    We then tried downloading the delta crl from a browser, and hit 404 - File or directory not found. Which then led us to the above article, the exact issue being at step 27.

    Thank you all for taking time to help on this.


    • Marked as answer by G2017 Thursday, October 25, 2018 11:02 AM
    • Edited by G2017 Thursday, October 25, 2018 11:22 AM
    Thursday, October 25, 2018 11:02 AM

All replies

  • Hi

    Did you update search content source from http to https and redo the full crawl?


    Justin Liu Office Servers and Services MVP, MCSE
    Senior Software Engineer
    Please Vote and Mark as Answer if it helps you.

    Tuesday, October 23, 2018 8:02 AM
  • I don't believe so, would you be so kind to let me know how you would do this? Thanks for getting back so quick btw!

    To update on this, we are running sharepoint 2010 foundation, so unsure on how to do what you proposed earlier. Most articles link to sharepoint 2013 on the above.

    If you are able to let us know how it is done, it would be much appreciated.

    • Edited by G2017 Tuesday, October 23, 2018 9:57 AM
    Tuesday, October 23, 2018 8:21 AM
  • Hello G2017

    1. Go to Central Administration

    2. click Application management

    3. Under Service Applications click "Manage Service Application"

    4. click Search Service Application

    5. Under Crawling click "Content Sources"

    6. Open the Local SharePoint Sites content source or any specific one you might have created for your web application/site.

    7. Change the URL from http to https.

    8. Select check box for Start Full crawl of this content source and click OK.

    Best Regards,


    Vaibhav Antriwale

    Tuesday, October 23, 2018 9:58 AM
  • Thank you for getting back to us, unfortunately we do not have this setting in the location specified.

    Please advise where on sharepoint foundation 2010 we are able to perform "update search content source from http to https and redo the full crawl".

    Many thanks in advance.

    Tuesday, October 23, 2018 10:25 AM
  • Since you are running SharePoint Foundation 2010. Please follow below steps:

    1. Services on Server -> SharePoint Foundation Search service is started.
    2. Monitoring -> Job Definitions -> SharePoint Foundation Search Refresh -> Run Now

    This will start a Full Crawl. Depending on the content it will take some time before search results starts appearing.

    As far as I can remember this will solve your issue. I do not have a SharePoint 2010 foundation environment so won't be able to reproduce the issue. Perform above steps and let us know.

    Best Regards,


    Vaibhav Antriwale


    Tuesday, October 23, 2018 12:04 PM
  • Thank you for your reply.

    1. I can confirm the service is started

    2. I have done a run now where you suggested.

    However we are still unable to search correctly. I am seeing the following in the event viewer app logs:

    The start address sts4://servername/contentdbid={ff8ecec4-9903-42bb-8fab-4c1c22cf3f23} cannot be crawled.

    Are you aware of how to do the 'update search content source from http to https' which Justin Liu_FoxDave suggested?

    Tuesday, October 23, 2018 12:46 PM
  • Hi

    My suggestion is also based on SharePoint server.

    But since your version is Foundation, there seems like no extra settings for search.


    Justin Liu Office Servers and Services MVP, MCSE
    Senior Software Engineer
    Please Vote and Mark as Answer if it helps you.

    Wednesday, October 24, 2018 5:49 AM
  • Hi G2017, 

    You said that you remove the binding in iis for port 80, and changing the website addressing in central administrator>app management>configure alternate access mappings.

    Make sure you add the binding in iis for port 443.

    SharePoint Foundation Search not working for your reference:

    http://shareplex.blogspot.com/2011/09/sharepoint-foundation-search-not.html

    Best Regards, 

    Lisa Chen 



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, October 24, 2018 7:39 AM
    Moderator
  • Thank you for the update, the binding for the sharepoint site is there for 443. I have had to put the settings back into a configuration we know works for the moment(this can be seen at the bottom).

    The only way the search appears to work at the moment is by going to http://servername and searching. Anything else e.g. http://intranet https://intranet http://intranet.domain.local https://intranet.domain.local simply returns 'We did not find any results for examplesearch.', and the error in the app log of The start address sts4://app00003/contentdbid={ff8ecec4-9903-42bb-8fab-4c1c22cf3f23} cannot be crawled.

    I have included the alternate access mapping and iis bindings below as they are at the moment. The current state is less than desirable, as at the moment we have placed the redirect to the servername for users to ensure they can use the service without issue.

    For completeness the certificate bound to 443 works and is trusted without issue on both short and fqdn of the site on https.

    Any further information required, please let us know.

    Wednesday, October 24, 2018 8:25 AM
  • Ok I think we have moved on a little today. So we have managed to resolve the search issue, however when opening any document on sharepoint under https, the document opens and then we see the following:

    (I am able to browse to the CRL DP of this certificate when I hit view cert>details tab>CRL Distribution Points>URL>copy and paste into browser, from both my computer and the sharepoint server. This prompts for open/download of the revocation list as expected. Also in iis, the website>ssl settings>client certificates>is set to ignore.)

    I still think this has something in part to do with the access mappings. I have tidied these up to look as below:

    Which brings the search back to life, however now creates the issue we are seeing above. I am assuming this is due to us visiting the https://intranet or https://intranet.domain.local link of the site, but the content is still all hosted on http://servername? To add, changing the ‘Default’ entry shown above from http://servername to https://servername brakes the search function also.

     

    Does anyone know how to resolve this, I am guessing this is the easy bit now……….?

     

    I am still having to redirect users to the http://servername as we know this is "working".





    • Edited by G2017 Wednesday, October 24, 2018 10:54 AM
    Wednesday, October 24, 2018 9:24 AM
  • I have now resolved everything with this. It was due to a setting in iis that had not been set for the CRL. I found the answer to the issue at the bottom of this article:

    https://knowledge.zomers.eu/misc/Pages/How-to-publish-Active-Directory-Certificate-Services-Certificate-Revocation-List-on-the-internet.aspx

    Turning on 'Allow double escaping' solved this.

    To get to this I used a mixture of fiddler and certutil -URL "http://crl.domain.com Issuing CA.crl", which showed me the CDP had failed, but I was able to download and resolve this as mentioned previously in a browser.

    We then tried downloading the delta crl from a browser, and hit 404 - File or directory not found. Which then led us to the above article, the exact issue being at step 27.

    Thank you all for taking time to help on this.


    • Marked as answer by G2017 Thursday, October 25, 2018 11:02 AM
    • Edited by G2017 Thursday, October 25, 2018 11:22 AM
    Thursday, October 25, 2018 11:02 AM
  • Thank you for sharing. It will help others who meet similar issue.

    Justin Liu Office Servers and Services MVP, MCSE
    Senior Software Engineer
    Please Vote and Mark as Answer if it helps you.

    Friday, October 26, 2018 1:41 AM