none
ECT (External Content Type) not visible in Site RRS feed

  • Question

  • Hi SharePoint Gurus,

    I am a novice to SharePoint environment and as part of learning, I am following an example on how to author an ECT using Visual Studio and subsequently developing .NET assembly connector.

    Everything went well except I could not find the ECT when I am trying to create an external list in a site using Site Actions -> More Options -> List -> External List. The ECT I have created above is not visible in the Data Source Configuration section of the External List configuration window.

    I have already set the permissions on ECT for the user I am trying to logon.

    The site URL I am trying to create external list in is : http://vishwaksena/sites/BICenter/BISubSite/

    The site URL I have provided while creating ECT in visual studio is: http://vishwaksena/sites/BICenter/BISubSite/

    The full qualified name of the ECT I am looking for is: BDCTutorial.BdcModel1.Entity1

    Here is the screenshot from VisualStudio:

    ECT in VisualStudio

    ECTNotFound

    I really appreciate if anyone could help me solve this problem.

    Thank you

    Hari.


    Haricharan.

    Saturday, April 7, 2012 2:52 PM

Answers

  • Hi Santoor,

    Can you see the ECT if you try to debug it from Visual Studio by pressing F5 button? Did you change site URL after the project was created? Can you try to validate this url when you create BDC Model project in Visual Studio.


    Dmitry

    Lightning Tools LogoLightning Tools Check out our SharePoint tools and web parts | Lightning Tools Blog

    • Marked as answer by Shimin Huang Friday, April 20, 2012 7:45 AM
    Thursday, April 12, 2012 9:59 PM

All replies

  • Maybe you couldn't have permission to view the ECT file. Ensure you have permission for BCS Model in Central Administration

    Regards,
    Shantha Kumar .T | MCPD - SharePoint Developer 2010 | MCITP - SharePoint Administrator 2010
    (B) Shantha Kumar's Blog | (T)Follow me

    Saturday, April 7, 2012 2:56 PM
  • Hello Shantha Kumar,

    Thanks for your response. I did set the permissions for the user (Administrator). Please see the below image and let me know if I need to do anything else to make it work. I really appreciate it.

    BDCPermissions

    Thank you

    Hari.


    Haricharan.

    Saturday, April 7, 2012 4:04 PM
  • Hi Santoor,

    What is scope of the feature in this project?


    Dmitry

    Lightning Tools LogoLightning Tools Check out our SharePoint tools and web parts | Lightning Tools Blog

    Monday, April 9, 2012 11:20 AM
  • Also check the Central Admin -> Business Connectivitiy Services application weather your external content type is there deployed or not.

    Regards, Dharnendra Shah "strong belief is the only way to success"

    Monday, April 9, 2012 1:28 PM
  • It is "Farm" scoped feature. Is that the right one?

    Thanks


    Haricharan.

    Wednesday, April 11, 2012 7:04 AM
  • Yes, I can see it in Central Admin -> BCS.


    Haricharan.

    Wednesday, April 11, 2012 7:05 AM
  • Hi Santoor,

    Can you see the ECT if you try to debug it from Visual Studio by pressing F5 button? Did you change site URL after the project was created? Can you try to validate this url when you create BDC Model project in Visual Studio.


    Dmitry

    Lightning Tools LogoLightning Tools Check out our SharePoint tools and web parts | Lightning Tools Blog

    • Marked as answer by Shimin Huang Friday, April 20, 2012 7:45 AM
    Thursday, April 12, 2012 9:59 PM