none
Disabling Infopath Session Time Outs RRS feed

  • Question

  • Howdy, just wondering if anyone knows the best way to disable session time outs for really long forms. Here's the error message I get:

     

    Critical Error
    Powered by:
    There has been an error while loading the form.
    Click Start Over to load a new copy of the form. If this error persists, contact the support team for the Web site.

    Click Close to exit this message.
    Hide error details
    For your protection, the current session has been terminated due to inactivity.

     

     

    I have the Form Session State setting set to 1440 minutes or 24 hours but it i'm still getting this error prior to this. Any suggestions on what else to change?
    Thursday, April 17, 2008 9:45 PM

All replies

  • Hi Henry,

     

    I'm having the same problem. Any luck with a solution?

     

    Alana

     

    Monday, April 21, 2008 5:03 AM
  • More than a year later, but I just came across this post regarding the session timeout:

    "It's configured through Central Admin ->Application Management but not the setting that I first thought.

    There is a setting under  Congifure InfoPath Forms Services for Form Session State and within there there's an entry for "Active sessions should be terminated after" which by default is set to 1440 minutes, so I thought why are they timing out.

    It turns out that the setting you actually want to change is in "Configure Session State" under Office SharePoint Server Shared Services which by default is set to 60 minutes."

    Read the full thread here: http://www.infopathdev.com/forums/p/7375/27329.aspx
    Thursday, June 4, 2009 11:16 PM
  • Sorry that I wasn't around yet when you wrote this else I would have pointed you to the session state.  Remember that this doesn't just affect browser forms, but rather it affects the browser session state for all of SharePoint, so please modify it with great care.

    Instead of changing this, which can be dangerous, I try to make my users aware that if they are filling out any forms that take a long time, then they need to save periodically, and I let them know exactly what the timeout duration is.
    SharePoint Architect - Planet Technologies - 4-Year Microsoft Federal Partner of the Year (2005-2008)
    Friday, June 5, 2009 12:07 AM
  • But it's Not Work Properly.

    As i set default time 100 minute. but it's give error i think after 50 min.

    Can any one tell me exactly what is the default session time for infopath browsing form.

    can we give any alert for user who using the site that time.. by which they save Form..

    Ankit jain

    Saturday, June 6, 2009 6:44 AM
  • There is no default for InfoPath browser forms.  The limit is caused by the browser, and that is a 60-minute limit set by default in SharePoint.  You can raise that limit, and yes it does work if you change the right setting - Configure Session State (in Central Admin).  It is not part of Forms Services configuration.
    SharePoint Architect - Planet Technologies - 4-Year Microsoft Federal Partner of the Year (2005-2008)
    Saturday, June 6, 2009 7:39 AM
  • But how can i give alert message to user... by which they draft their document.. before it's lost..

    Ankit jain
    Saturday, June 6, 2009 8:06 AM
  • There isn't a way.  You need to train your users to know how long the timeout is, or you need to raise the timeout to a very high amount.  There may be some way of creating something with code, but you can't do any pop-ups in browser-enabled forms.
    SharePoint Architect - Planet Technologies - 4-Year Microsoft Federal Partner of the Year (2005-2008)
    Saturday, June 6, 2009 2:38 PM
  • Ok.. thnks..Cobb..

    But i think there Should be any method by which I can alert user before it's Going to session out..

    Ankit jain
    Tuesday, June 9, 2009 9:50 AM
  • You can submit then switch to a view that only has text confirming a successful submit.  Then, that page can have a close button that does nothing but close.
    SharePoint Architect - Planet Technologies - 4-Year Microsoft Federal Partner of the Year (2005-2008)
    Tuesday, June 9, 2009 2:14 PM
  • I done this..

    But My Client Requirement why u switch the view.. he just want to close by submit button...

    Ankit jain
    Wednesday, June 10, 2009 5:37 AM
  • That's unreasonable.  If you want a message, use rich client forms.  If you want browser forms, then suck it up and deal with the fact that some things are missing.
    SharePoint Architect - Planet Technologies - 4-Year Microsoft Federal Partner of the Year (2005-2008)
    Wednesday, June 10, 2009 7:25 AM
  • What setting is required to be changed in SharePoint to increase this 60 minute timeout?

    Session State is disabled in Web.config by default - so what exactly is InfoPath using? Some sort of hidden database session state that SQL Agent manages?


    • Edited by Peter_D503 Tuesday, March 18, 2014 4:54 AM
    Tuesday, March 18, 2014 4:54 AM