none
webpart zone has "noindex" class by default RRS feed

  • Question

  • Hello,

    •   I have a page layout . and I add a web part zone in it .
    •   I create a custom web-part that read from List . And added on the page .
    •  I configure search successfully.
    •  When I search for a word  in the list , The result search don't display the link of the page that has a web part.
    • I notice in the rending the web part zone has a class "noIndex" by default

           <div webpartid="ddc2a055-278d-4cb3-a573-632aedfd2ba3" haspers="false" id="WebPartctl00_ctl35_g_ddc2a055_278d_4cb3_a573_632aedfd2ba3" width="100%" class="ms-WPBody noindex " allowdelete="false" allowexport="false" style=""><div id="ctl00_ctl35_g_ddc2a055_278d_4cb3_a573_632aedfd2ba3">

     I  think the search cannot search inside this web part because this class , How Can I remove it ?

      Thanks


    ASk

    Tuesday, September 30, 2014 5:39 PM

Answers

  • its a site property to index web parts

    Site Settings -> Search and Offline Availability

    Indexing ASPX Page Content -> Always index all Web Parts on this site


    -tom daly

    Thursday, October 2, 2014 7:47 PM

All replies

  • its a site property to index web parts

    Site Settings -> Search and Offline Availability

    Indexing ASPX Page Content -> Always index all Web Parts on this site


    -tom daly

    Thursday, October 2, 2014 7:47 PM
  • The web parts were taking lot of extra space after enabling this property. The issue has been fixed after disabling it. Thanks for the post.

    Furqan Ahmad

    Wednesday, January 28, 2015 7:07 AM