none
MUI Language pack issue on windows 10 Entprise 1809 version RRS feed

  • Question

  • Hi ,

    i have MUI language pack ISO and with that i have installed the other language(by default is English  ) by the help of lpksetup 

    i have all .cab file and it went for installation successfully, but later i have check control penal-> clock language and region>

    there is only one option change date ,time or number formats, So because of that i am not able to find the add language option

    -In perivous windows 10 1607 version there was a setting which is control penal-> clock language and region->add a languge 

    there we can easily find the install language packs which we have done here this 1809 version alos, but in 1809 i am not able to find the setting, Even latar i have try to find the insatallled pack( which i have downloaded by the our ISO (help lpkstep)} by the powershell admin cmd Get-WinUserLanguageList but i didnt find the insatlled langauge pack. 

    Please suggest me how to achived same in new windows 10 1809 version 


    Wednesday, May 22, 2019 12:41 PM

All replies

  • Hello san va,

    Please check if you find the Windows 10 LP option and set the language to multilanguage in your image.

    Here is another topic Windows 10 ENT 1809 add Language issue. Hope it is helpful for you.

    In addition, this documents shows how to add languages to Windows images, you may try to refer to this document.

    Best Regards,

    Michael


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, May 23, 2019 1:56 AM
    Moderator
  • dear Michael,

    as i said the .cab file which i sunder the MUI package it went successfully for installation but it not showing in my setting, even in windows 10 1809 version micorosft remove the Add a language setting under the control penal ,

    So how to acived the same as i already installed the language cab file.

    you said "Please check if you find the Windows 10 LP option and set the language to multilanguage in your image"

     i want know which Windows 10 LP option you are taking and how to set the language to Multilanguage in image

    as i want clear some point i have MUL language pack ISO

    under this iso i have 4 option 

    arm64

    LocalExprincePack

    Windows Preinstallation  Environment 

    x64

    x86

    what i am doing i have windows 10 installed in my system and i am running the cmd lpksetup 

    from under the X64 i am selecting the .cab file for any language after browsing the installation is going successfully but later the i am searching the installed .cab language pack is not there i have found under control penal but the add a language option is also missing so how to get the same 

    Thursday, May 23, 2019 3:03 AM
  • Hello san va,

    In Windows 10, version 1809, LIPs are delivered as Local Experience Packs (LXPs) .appx files, for example, LanguageExperiencePack.am-et.neutral.appx. For previous versions of Windows 10, LIPs are delivered as .cab files, for example, C:\Languages\es-ES\lp.cab. You need to check if the LP is added in the installation image. If not, you can use following command to add the package:

    Dism /online /Add-Package /PackagePath:

    Best Regards,

    Michael


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, May 23, 2019 6:07 AM
    Moderator
  • I am having the same (I think) issue. If I use DISM to install the ja-JP language pack using /online /add-package, it will install successfully. However, the language does not show up in the list for the user to select.

    I followed the guide from MS on packaging/deploying with SCCM.

    I verified that the language is installed. When i run dism.exe /online /get-intl, it shows that ja-JP is installed... however if i go to Language settings, the only language I see is English. (It does this same with all languages... i currently installed es-MX and ja-JP and both show up in /get-intl... but they do not show in the language settings).



    • Edited by Ben Dudley Monday, September 23, 2019 5:44 PM left out MS
    Monday, September 23, 2019 5:44 PM
  • It seems that after installing the CAB file using DISM on Windows 10 1809, you still have to do more to add the language to the list in the language settings. There are a couple powershell commands you can run to do this... but they have to be run AS THE USER that needs to select the language. In my case (and maybe others), there does not appear to be a way to add languages to a machine during build time and have those languages available for any user to select.

    For reference, here is what works for me:

    Installing ALL language CAB files (client language pack plus ALL FOD CAB files) via DISM:

    Get-ChildItem -filter *.cab | % {Add-WindowsPackage -Online -PackagePath $($_.name)}

    After they are all added, run these commands (Japanese for example):

    $LangCode = "ja-JP"
    $langs = Get-WinUserLanguageList
    $langs.add($LangCode)
    Set-WinUserLanguageList $langs -force

    I hope this helps others.

    Wednesday, October 9, 2019 8:15 PM