none
Visual Studio 2015를 실행하면 투명한 화면으로 표시됩니다.

    질문

  • Visual Studio 2015를 실행하면 투명한 화면만 나오고 검정색 태두리만 나옵니다.

    어떻게 해야 되나요?

    2017년 2월 2일 목요일 오전 9:00

모든 응답

  • 안녕하세요~ 처음 보는 증상이지만,

    visual studio에 대한 시스템 요구사항 한번 확인해보시구 재설치 해보세요!

    시스템 요구사항:

    https://www.visualstudio.com/ko-kr/productinfo/vs2015-sysrequirements-vs

    다운로드 페이지:

    https://www.visualstudio.com/ko/downloads/

    2017년 2월 2일 목요일 오후 11:31
  • 기존에 잘 사용하던 거고 몇달 안사용하다가 다시 사용하려고 하니까 안되네요.

    PC사양은 높은 거라 문제 될 것 같지는 않습니다.

    재설치를 하고 싶어도 재설치 화면 역시 안나와서 어떻게 해볼 수가 없어서 윈도수 다시 설치하려고 합니다.

    i5-6200U CPU@ 2.3GHz 2.4Hz

    8GB RAM

    SSD 180GB

    Intel(R) HD Graphics 520

    LG gram 14Z960-GA50K 모델입니다.

    입니다.

    2017년 2월 3일 금요일 오전 6:41
  • 저도 같은 증상이 있었는데(vscode 실행 시) 확인해보니 ios의 duet display 설치 시에 발생하더군요. 해당 프로그램을 삭제하니 다시 잘 보입니다. duet 측에 문의하니 amd 그래픽 카드와 호환성 문제라고 합니다. (제 노트북은 인텔 내장과 amd 글카 2개가 탑재) 저도 아직 amd 글카 설정을 안 바꿔봐서 테스트를 해봐야겠네요!
    2018년 10월 17일 수요일 오후 11:25
  • VS에서 그래픽으로 인한 문제는 대개의 경우 GPU 가속 기능으로 인한 것입니다. Tools / Options 메뉴에서 다음의 글에 설명하는데로 하드웨어 가속 기능을 꺼 보세요.

    Improving Performance by Changing the Visual Experience
    ; https://blogs.msdn.microsoft.com/zainnab/2010/06/22/improving-performance-by-changing-the-visual-experience/

    만약, 저 창까지 가기도 전에 투명한 화면으로 나온다면 일단 임시 방편으로 시스템 전역적인 WPF 응용 프로그램에 대한 GPU 가속 기능을 다음의 레지스트리 옵션으로 끄고,

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration
    DWORD 1

    Visual Studio가 정상적으로 뜬다면 Tools / Options 메뉴를 설정한 후 전역 레지스트리 설정은 끄면 됩니다.

    2018년 10월 18일 목요일 오전 5:54
  • 저 같은 경우는 amd 그래픽 카드를 비활성화하니 정상적으로 동작했었는데 visual studio는 말씀하신 대로 하면 될 것 같고 vscode는 위 옵션이 없어서 

    https://code.visualstudio.com/docs/supporting/FAQ#_vs-code-is-blank

    링크대로 하니 amd 그래픽 카드를 활성화해도 잘 되네요.

    아마 제가 설치한 duet이 강제적으로 하드웨어 가속을 사용하도록 했었나봅니다.

    감사합니다!


    • 편집됨 totozone17 2018년 11월 3일 토요일 오후 10:48
    2018년 11월 3일 토요일 오후 10:46