none
SP_Configure의 Run_Value 변경 RRS feed

  • 질문

  • SP_Configure 문의

    1. SQL Server 전용으로 사용하고 있음

    2. OS : Windows 2008 R2 Enterprise (64bit) SP1


    3. 시스템 : CPU(8코어), 메모리(32GB)

    4. SQL 버전 : SQL Server 2008 Standard(32bit) SP3 ( 10.0.5500.0)

    5. Max Sever Memory 변경

    sp_configure 'show advanced options', 1;
    GO
    RECONFIGURE;
    GO
    sp_configure 'max server memory (MB)', 29000;
    GO
    RECONFIGURE --WITH OVERRIDE
    GO

    위와 같이 변경시도를 했습니다.

    그러나 아래와 같이 구성 값은 변경이 되나 실행값이 변경이 안되고 있습니다.

    name : Max Server Memory (MB)
    minimum : 16

    Maximum : 2147~~~
    Config_value : 29000
    run_Value : 12288


    1. H/W 서버 리부팅 => 변경 안됨

    2. SQL Service 재시작 => 변경 안됨

    3. RECONFIGURE;
        GO    =>  

    구성 옵션 'max server memory (MB)'이(가) 29000에서 29000(으)로 변경되었습니다. RECONFIGURE 문을 실행하여 설치하십시오.
    메시지 5593, 수준 16, 상태 1, 줄 1
    WoW64에서는 FILESTREAM 기능이 지원되지 않습니다. 해당 기능이 비활성화됩니다.


    ========================================================

    더 점검해봐야 할사항이 어떤게 있을까요?

    도와 주세요.

    핵심은 run_value가 변경되지를 않습니다.(리부팅 후에도)

    현재는 단순히 윈도우(64bit)에 SQLServer(32bit)를 사용,  Wow64사용 때문에 라고만 추측하고 있습니다.

    아무리 자료를 찾아봐도 위와 같은 사례 및 해결방법을 찾을 수가 없네요.ㅠㅠ

    ========================================================

    2017년 3월 17일 금요일 오전 3:09

모든 응답

  • RECONFIGURE WITH OVERRIDE 로 하신거 맞나요?

    참조한 페이지는 아래입니다. 질문하신 내용과 거의 흡사합니다.

    http://www.sqlservercentral.com/articles/Clustering/103090/

    2017년 3월 17일 금요일 오전 6:42
  • 먼저 답변 감사합니다.

    위에는 주석처리 되어 있지만 RECONFIGURE WITH OVERRIDE 한것 맞구요~

    RECONFIGURE WITH OVERRIDE 또는 RECONFIGURE를 했을 경우에는

    =================================================

    구성 옵션 'max server memory (MB)'이(가) 29000에서 29000(으)로 변경되었습니다. RECONFIGURE 문을 실행하여 설치하십시오.
    메시지 5593, 수준 16, 상태 1, 줄 1
    WoW64에서는 FILESTREAM 기능이 지원되지 않습니다. 해당 기능이 비활성화됩니다.

    =====================================================

    이러한 메세지가 출력 됩니다.

    제가 이해하기로는 Wow64모드라서 그렇게 출력 되어진거로 보여서

    서버 리부팅 및 SQL Server 서비스 리스타트를 했는데도 마찬가지로 run_value의 값이 변함이 없네요.

    적지는 않아지만 아래 내용도 세팅되어 있습니다.

    - Awe Enable 사용

    - Min Server Memory는 세팅하지 않았음

    - 메모리 페이지 잠금 설정 하였음(SQL Server 시작계정 추가)

    그리고 링크 걸어주신 곳의 내용을 보았습니다.

    제가 이해할때는 주 내용이

    한 서버에 두개의 인스턴스가 존재할경우 

    한개의 인스턴스 실행시와 두개의 인스턴스 실행시 Max Server Memory 값을 달리 해주는 내용 같습니다.

    제 경우와는 차이를 보이는거 같네요..

    정말 힘드네요... ㅠㅠ

    현 상황에서 SQL을 64비트로 신규설치 운영을 해야 하는것인지.(하긴 신규설치가 현재로서는 좀 어려네요)

    위와 같은 방법밖에 없는것인지 아님 다른 무언가 세팅이 잘못되어서 그런것인지 답답합니다.~

    • 편집됨 podongpodong 2017년 3월 17일 금요일 오전 7:12
    2017년 3월 17일 금요일 오전 7:11
  • 먼저.. 안타까운 소식을 전해드려 죄송합니다. 

    "You cannot enable FILESTREAM on a 32-bit version of SQL Server running on a 64-bit operating system."

    라고 msdn에서 그러네용 ㅠㅠ 

    동일한 문제로 해외 포럼의 글이 있지만.. 동일한 대답 같습니다. 

    https://social.technet.microsoft.com/Forums/en-US/d8060fdd-4583-4bf7-bdcf-4fd053d5d2c0/unknown-error-applying-the-filestream-settings?forum=sqlsetupandupgrade

    • 편집됨 Scott Park 2017년 3월 17일 금요일 오후 12:35
    2017년 3월 17일 금요일 오후 12:34
  • 해결될 것 같습니다.

    먼저 말씀하신 wow64모드에서 Filestream 서비스는 안되는게 맞습니다.

    해결 방법은 누가 언제 이렇게 세팅을 해놨는지 모르겠~~~ㅠㅠ

    name                                minimum     maximum     config_value run_value
    ----------------------------------- ----------- ----------- ------------ -----------
    filestream access level             0           2           2            0

    위와 같이 세팅이 되어 있었습니다.

    config_value를 0으로 세팅을 한후에 모든것이 정상으로 해결될것으로 보입니다.

    https://social.msdn.microsoft.com/Forums/sqlserver/ko-KR/338bef5b-19ed-42f4-9fc3-75f03658d47a/contact-spconfigure-max-server-memory?forum=sqlsetupandupgrade&prof=required



    • 편집됨 podongpodong 2017년 3월 20일 월요일 오전 4:26
    2017년 3월 20일 월요일 오전 4:25
  • 해결되셨다니 다행이네요~ 덕분에 좋은 정보 얻어갑니다 ^^
    2017년 3월 21일 화요일 오전 3:38