none
vsinstr exclude doesn't work with '+' symbol RRS feed

  • 질문

  • I tried to exclude symbols while vsinstr-ing native exe module as following;

    vsinstr @cov.rsp


    cov.rsp is a text file including vsinstr options like this;
    /coverage
    /exclude:...
    /exclude:...
    /outputpath:..
    my.exe
    

    however, custom class with operator methods(operator+, operator+=) can't be excluded with /exclude: options.

    for example, /exclude:MyClass:operator+ doesn't work, which means coverage data contains MyClass::operator+.

    How can I exclude those operator overloaded methods (with '+' symbol)?

    2009년 11월 12일 목요일 오전 1:21