none
Linked Server MSSQL 2014 to MSSQL2000 RRS feed

  • 질문

  • 현재 설치된 환경은 Windows 2012 R2 Std + MS SQL 2014 EE입니다.

    기존에 사용하던 MS SQL 2000을 migration하기 위해 위와 같은 환경을 구성했는데요,

    2000 --> 2014로 바로 upgrade가 되지 않는 다는 것을 알고는 있는데, 그렇다고 해당 Server에 2008을 설치하기도 그러네요.

    그래서 구글링을 하다보니 아래와 같은 문서를 보게 되었습니다.

    https://blogs.msdn.microsoft.com/dbrowne/2015/05/15/how-to-create-a-linked-server-to-sql-2000-from-sql-2012-or-later/

    요지는 SQL Server 2008용 Feature-pack중 SQLNCLI10 driver를 이용하라는 것이더군요.

    그래서 해당 site로 가서 sqlncl_x86.msi를 download받은 후 설치하려니까 OS requirements에 부합된다고 설치가 안되네요.

    이 방법외에 단순히 SQLSRV32.dll을 이용해서 ODBC연결을 할 경우는 접속은 가능하나,

    일부 varchar column에 한자가 있을 경우 문제가 발생해서, 위의 SQLNCLI10을 사용하고자 하는 겁니다.

    방법이 없을까요? 도움을 부탁 드립니다.


    Thanks

    2017년 6월 21일 수요일 오전 5:14

모든 응답